Go Down

Topic: Problemas con paper-rs232 de txapuzas (Read 849 times) previous topic - next topic

riscking

Nadie sabe porque puede funcionar sin esa resistencia y con ella no funciona??

Inizul

#6
Feb 08, 2012, 11:52 pm Last Edit: Feb 08, 2012, 11:57 pm by Inizul Reason: 1
Hola Risking,

En realidad, según el datasheet del max232, no son necesarias las resistencias en las señales Rx y Tx, pero como vi que yopero había hecho el circuito con Reset Automático (yo simplemente había hecho un circuito de conversión RX y TX sin Reset automático), copié el circuito de Yopero, y no me dió ningún problema (quizás tengan un valor muy alto).

http://yopero-tech.blogspot.com/2011/03/arduino-rs232.html

Lo único que se me ocurre es que si utilizan condensadores muy pequeños, no lleguen a acumular la suficiente energía como para que las "bombas de carga" del circuito MAX232 funcionen correctamente.

Siento las molestias  :smiley-sad-blue:

riscking

Inizul molestias ninguna q bastante te lo curras.y hay q agradecertelo, luego probare con resistencias mas pequeñas a ver q tal, los condensadores son de 1uf 100v q no creo q tengan q ver q no sean de 16v no?

yOPERO

#8
Feb 09, 2012, 05:55 pm Last Edit: Feb 09, 2012, 06:05 pm by yOPERO Reason: 1
1uf- 100v  ??? :smiley-eek:  ceramico o polarizado?
Engineering is the art of
making what you want from
things you can get.

     

[SOLUCIONADO]

riscking

Electrolitico de 1uf 100v y uno de lenteja cerámico de 100nf para el reset, vamos como el paper. salvo que en vez de 16v son de 100v porque no tenian de menos pero supongo que no deberia influir porque es lo q aguanta o eso entiendo yo.

Go Up