Pages: [1]   Go Down
Author Topic: sketch_feb09a empty  (Read 897 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi. Im trying to upload the sketch_feb09a.ino but I always hace the same error
"core.a(main.cpp.o): In function `main':
C:\arduino-1.0\hardware\arduino\cores\arduino/main.cpp:11: undefined reference to `setup'
C:\arduino-1.0\hardware\arduino\cores\arduino/main.cpp:14: undefined reference to `loop'"

The file size is 0 kb and after starting arduino.exe there is nothing on the screen

Is an Aduino UNO on COM12 usb port running with XP
Leds are flashing ok

What's wrong?
Logged

North Queensland, Australia
Offline Offline
Edison Member
*
Karma: 74
Posts: 2209
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Thats cos your file size is 0 bytes. enlarge it with a couple of functions.

Code:
void setup(){

}
void loop(){

}

main.cpp calls these functions to start your sketch, you need to define their contents.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Shouldnt I see something on the screen (commnands) when sketch_feb09a is opened? There is nothing. By adding what you say now there are no errors. I mount an Aeroquad 1.9 shield and still does'nt work.
Sorry for my unexperience but Im lost.
Logged

Miramar Beach, Florida
Offline Offline
Faraday Member
**
Karma: 148
Posts: 6104
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That sketch won't always be empty. If you enter something there, then save it as that sketch name, it will not be empty.

Tomorrow, the empty sketch will be sketch_feb10a

Mine always loads a "new" sketch window. I don't know if it is supposed to do that, but mine always has.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Is it possible to get just the file? Where? When installing Arduino software I understand that it is included the sketch, but it shows empty.
I understand there is no way to make running the  Aeroquad shield if I dont upload first the sketch_feb09a or 10a. Is it so?
Logged

Leighton Buzzard, UK
Offline Offline
Edison Member
*
Karma: 21
Posts: 1339
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

er that's the default name for an empty sketch!
Logged

there are only 10 types of people
them that understands binary
and them that doesn't

Sunnyvale, CA
Offline Offline
Full Member
***
Karma: 0
Posts: 147
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

LOL.


Sorry, but it's funny.  I have a feeling this guy is trolling.

When you open the IDE it defaults to sketch and the current date.  OF COURSE it's going to be empty. you have to enter code!  You want it to do something, load an example then compile.    Tomorrow when you open the IDE it'll have a new date, with an empty sketch.

Trololololol
Logged

My first major project (looking for people who would like to help contribute) Bluetooth Sure 32x16 LED Displays!: https://github.com/evanric

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

He may be trolling but I'm not.

I see the date as sketch name when I start the software.  But I'm not able to type anything.  I can't paste anything.
I can load up an example, compile and send it to the board.  BUT I can't change anything in the code.

I've been able to use the software (0022) fine in the past.  I loaded 1.0 and have the same thing happen.

Has anyone seen this?

kk
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 222
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

External editor selected in preferences?
Logged

Pages: [1]   Go Up
Jump to: