Pages: [1]   Go Down
Author Topic: Problema compilazione  (Read 334 times)
0 Members and 1 Guest are viewing this topic.
Cuneo
Offline Offline
Newbie
*
Karma: 0
Posts: 21
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao smiley
perchè quando aggiungo librerie esterne mi da errore sulla libreria wprogram.h?
Logged

Rovereto
Offline Offline
Full Member
***
Karma: 0
Posts: 152
La luce e' piu' veloce del suono. Per questo motivo alcune persone sembrano brillanti fino a quando non parlano.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Se stai usando l'IDE 1.0 di Arduino, allora wprogram.h non esiste e quindi non viene trovato dalla libreria esterna.

Ciao
QP
Logged

Cuneo
Offline Offline
Newbie
*
Karma: 0
Posts: 21
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

come faccio a risolvere?
Logged

Rovereto
Offline Offline
Full Member
***
Karma: 0
Posts: 152
La luce e' piu' veloce del suono. Per questo motivo alcune persone sembrano brillanti fino a quando non parlano.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Credo che la via più rapida sia utilizzare l'IDE 022 o 023. Almeno mantieni la compatibilità con le librerie esterne che non sono ancora state aggiornate alla 1.0

Ciao
QP
Logged

Cuneo
Offline Offline
Newbie
*
Karma: 0
Posts: 21
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok funziona smiley
grazie 1000! smiley
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 332
Posts: 22817
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Cercati la soluzione nei vecchi post. Si tratta di aggiungere un check in cima alla lib per verificare la versione dell'IDE.

Code:
#if defined(ARDUINO) && ARDUINO >= 100
#include "Arduino.h"
#else
#include "WProgram.h"
#endif
Logged


Pages: [1]   Go Up
Jump to: