Go Down

Topic: problema con livelli di tensione RS232 (Read 489 times) previous topic - next topic

stefa24

ciao
vorrei collegare un modem con uscita RS232 femmina, ho misurato questi livelli di tensione
2 tx 9v
3 rx 3.2v
da quello che ho letto credo mi serva un max232, me lo confermate?
sullo shield dove è montato il modem vero e proprio, c'è già un max232,
ho fatto alcune misure e in entrata a questo max232 misuro 1.5v sul pin 11 e 0v sul pin 12, allego schemi,
se tolgo il max e faccio un ponte tra i pin 11<-->14 e tra i pin 12<-->13 faccio una cavolata?

grazie
stefano
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

ratto93

conviene sempre usare un max232 mentre ti interfacci a circuiti che non conosci a menadito.. per di più senza uno schemino si capisce poco :)
Se corri veloce come un fulmine, ti schianterai come un tuono.

stefa24

scusate avevo dimenticato l'allegato
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

uwefed


ciao
vorrei collegare un modem con uscita RS232 femmina, ho misurato questi livelli di tensione
2 tx 9v
3 rx 3.2v
da quello che ho letto credo mi serva un max232, me lo confermate?
sullo shield dove è montato il modem vero e proprio, c'è già un max232,
ho fatto alcune misure e in entrata a questo max232 misuro 1.5v sul pin 11 e 0v sul pin 12, allego schemi,
se tolgo il max e faccio un ponte tra i pin 11<-->14 e tra i pin 12<-->13 faccio una cavolata?
grazie
stefano

Dovrebbe funzionare. Attenzione non potrai piú collegare la exRS232 al Computer o similari che hanno una RS232.
Ciao Uwe

Go Up