Pages: [1] 2   Go Down
Author Topic: messaggio di errore: avrdude: stk500_getsync(): not in sync: resp=0x30  (Read 3495 times)
0 Members and 1 Guest are viewing this topic.
Imperia
Offline Offline
Newbie
*
Karma: 0
Posts: 45
geofisica & datalogger
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

messaggio di errore

Chi mi sa dire quale problema ha l'arduino uno  quando in fase di caricamento ( ultimo secondo ) scrive questo messaggio di errore :

 Binary sketch size: 3626 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30

grazie
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 313
Posts: 21624
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Per favore leggi:
http://arduino.cc/forum/index.php/topic,90375.0.html
Logged


Imperia
Offline Offline
Newbie
*
Karma: 0
Posts: 45
geofisica & datalogger
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

purtroppo c'è poco da spiegare

Quale arduino usi?        arduino uno
Come lo alimenti?         usb
Che codice usi?           qualsiasi codice degli esempi di arduino programma
versione del programma  l'utima scaricata oggi e la 22 precedente

la domanda la rivolgo a chi in passato ha avuto il medesimo problema.

carico il programma,
lucetta verde accesa,
lo compilo , tutto ok
faccio partire il caricamento- barra verde arriva al 90 %  tutto ok
alla fine compare il messaggio di errore

avrdude: stk500_getsync(): not in sync: resp=0x30

ho anche provato a cambiare l' ATMEGA e non sono state fatte operazioni di montaggio hardware nuove, il giorno precedente tutto ok, il problema i ha anche con l'ARDUINO SCOLLEGATO TOTALMENTE ALL'hRDWARE.
grazie dolmetta angelo



Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 313
Posts: 21624
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Che versione di Arduino? R1, R2, R3?
Te lo fa da nuovo, ossia da appena scartato?
Se non è nuovo, è già stato usato? Hai un altro programma caricato sull'Arduino?

I led RX/TX come sono? Accesi, spenti, lampeggianti, sono spenti e si mettono a lampeggiare durante il caricamento dello sketch?

Logged


Imperia
Offline Offline
Newbie
*
Karma: 0
Posts: 45
geofisica & datalogger
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Che versione di Arduino? R1,
ha sempre lavorato bene ed è stato acces normalmente il giorno dopo chhe funzionava bene.

Se non è nuovo, è già stato usato? Hai un altro programma caricato sull'Arduino? tutti i programmi che carico demo arduino compresi compila, carica dino al 90% poi si ferma e da il messaggio di erroere 

I led RX/TX come sono? Accesi, spenti, lampeggianti, sono spenti e si mettono a lampeggiare durante il caricamento dello sketch?
 lsono accesi e lampeggiano normalmente dino al 90% del caricamento, poi si pianta  led verte rimane acceso, led giallo lampeggiafe smette di lampeggiare.

ho anche provato a cambiare l' atmega,

comunque grazie 
Logged

Deep south of Italy
Offline Offline
Faraday Member
**
Karma: 7
Posts: 2961
The quieter you become, the more you can hear
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hai controllato che la porta seriale impostata sull'ide sia la stessa che ti riconosce il sistema operativo quando connetti arduino?
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 414
Posts: 11987
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

A mio avviso non può essere un problema di configurazioni, visto chela procedura da' errore quasi alla fine e non quanto tenta l'inizio del caricamento. A me sembra un problema legato all'atmega8u2. Ho trovato questa discussione, da quello che ho capito sembra proprio un problema del convertitore USB-seriale. In quel Topic c'è un link relativo alla ri-programmazione dell'8u2. Qui sul Forum l'ha fatta più di qualcuno, con successo; a questo punto ti conviene fare questo tentativo: se la programmazione va a buon fine sei a posto, se ti da' errore significa che si è danneggiato il chip e lì diventa problematico, speriamo di no.
Logged

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Deep south of Italy
Offline Offline
Faraday Member
**
Karma: 7
Posts: 2961
The quieter you become, the more you can hear
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

messaggio di errore

Chi mi sa dire quale problema ha l'arduino uno  quando in fase di caricamento ( ultimo secondo ) scrive questo messaggio di errore :

 Binary sketch size: 3626 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x30

grazie
@manny ma se il messaggio è quello che leggo in cima, mi sà che per "verso la fine" lui intende di tutto il processo di compilazione/upload , e quindi la "fine" non è altro che l'upload che non trova una seriale con cui parlare, no?
dolfrang correggimi se ho capito male, il messaggio di avrsize è praticamente l'ultima fase della compilazione, il passo successivo è l'upload (dove avrdude ti dà errore)
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 313
Posts: 21624
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Un attimo.
Lui dice di avere un Arduino R1, è una scheda che ha 1 anno di vita. Ed in tutto questo frangente non lo ha mai usato? Mi suona strano!

Secondo me sta usando l'IDE 1.0 e non lo ha detto. Lo intuisco dal fatto che dice che c'è una barretta verde in basso che arriva al 90%, e questa barretta è comparsa nell'ultima versione. Con l'IDE 0022 funzionava tutto e con l'IDE 1.0 no?

Poi non ha risposto all'altra domanda: se cioè c'era un altro sketch caricato sopra. Che sketch era? E' stato messo con l'IDE 1.0 oppure prima?

Insomma, dare più informazioni, essere più precisi. La mia sfera di cristallo è rotta e non riesco a vedere bene le cose.
Logged


Deep south of Italy
Offline Offline
Faraday Member
**
Karma: 7
Posts: 2961
The quieter you become, the more you can hear
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

infatti io pensavo che l'installazione del nuovo ide il file di configurazione fosse stato sovrascritto con quello di default, magari ha anche la board errata...
Logged

Global Moderator
Milano, Italy
Offline Offline
Edison Member
*****
Karma: 15
Posts: 1163
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

L'ultimo sketch che hai caricato, continua a funzionare? faceva parecchio uso della seriale? Se apri il monitor Seriale cosa succede? I led RX e TX lampeggiano appena colleghi la board al computer oppure solo mentre stai facendo l'upload? Tieni presente che non dovrebbero cominciare a lampeggiare appena parte la progress bar, ma solo dopo un po' (quando ha finito di compilare). L'atmega che hai sostituito lo hai inserito nel verso giusto?

Potrebbe essere veramente un problema legato al firmware dell'8u2 che è stato aggiornato per correggere alcuni bug. Prova ad eseguire la procedura di aggiornamento, il firmware da caricare lo trovi nella cartella ~/hardware/arduino/firmware il file giusto dovrebbe essere "UNO-dfu_and_usbserial_combined.hex" e questa la guida da seguire.
Logged

F

Deep south of Italy
Offline Offline
Faraday Member
**
Karma: 7
Posts: 2961
The quieter you become, the more you can hear
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Millesimo posti di Federico!
scatta la fiesta?
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 414
Posts: 11987
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

@ Leo: è vero che le info se le fa tirare un po' con le pinze  smiley-confuse ma comunque ti ha risposto
Quote
ha sempre lavorato bene ed è stato acces normalmente il giorno dopo chhe funzionava bene.
quindi in precedenza ha funzionato, un bel (si fa per dire) giorno non ha funzionato più. Concordo sul fatto che stia usando l'IDE 1.0, ma penso che se la cosa fosse stata coincidente avrebbe riprovato a mettere la 0022/3.

@ BB: sì, ho capito perfettamente che sta arrivando quasi alla fine del caricamento quindi il dialogo con la seriale c'è, è proprio per questo che penso ad un danno software e non hardware dell'8u2

@ Federico: condivido l'idea di un possibile blocco della seriale, magari il classico sketch che in loop inizia subito a sparae dati al serial monitor, ma in questo caso la sostituzione dell'atmega avrebbe dovuto risolvere, e dubito che l'abbia messo al contraio, non penso che in questo caso sarebbe arrivato al 90% dell'upload smiley-cool
Logged

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Novara
Offline Offline
Newbie
*
Karma: 0
Posts: 28
"Parhea mota, unn' era! " Anonimo toscano
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Mentre facevo delle prove per riuscire a programmare un Attiny85 con Arduino as ISP ho ricevuto anche io un errore simile proprio ieri il mio, si vede dalla immagine restituisce resp=0x15.
Non ho ancora risolto il problema, ma credo (sono  sicuro, direi!) dipenda dalla istallazione e dai file di configurazione della IDE.
Ripeto NON ho ancora risolto, ma ve lo segnalo sperando serva a qualcosa


* prob-7.jpg (16.28 KB, 431x180 - viewed 52 times.)
Logged

Valerio

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 414
Posts: 11987
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Mentre facevo delle prove per riuscire a programmare un Attiny85 con Arduino as ISP ho ricevuto anche io un errore simile proprio ieri il mio, si vede dalla immagine restituisce resp=0x15.
Non ho ancora risolto il problema, ma credo (sono  sicuro, direi!) dipenda dalla istallazione e dai file di configurazione della IDE.
Ripeto NON ho ancora risolto, ma ve lo segnalo sperando serva a qualcosa
No, quello è l'errore dell'autoreset, significa che devi usare il condensatore; la soluzione migliore, che abbiamo trovato successivamente, è quella di infilare il polo positivo del C nel pin 3V3 di Arduino ed il polo negativo nel pin RESET. COme già detto il C va usato solo nelle fasi di caricamento ISP, va poi levato quando bisogna inviare sketch ad Arduino.
Logged

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Pages: [1] 2   Go Up
Jump to: