Pages: [1]   Go Down
Author Topic: Arduino mini "yikes invalid device signature arduino mini avrdude" for blink  (Read 1939 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I just purchased 3 Arduino mini w/328 from mouser. I tried loading blink on to all three, all of them retruned the "yikes invalid device signature arduino mini avrdude" error. I just downloaded the AVR environment and I don't have any other instances of AVRdude on my computer. I am using windows 7. My board and serial port settings are correct. What can be the issue?

- Do I need to set a specific path for the arduino folder that I just downloaded? Currently its just on my desktop.
- What programmer should I choose under tools, if I'm using the mini USB adapter? I tried a bunch of them, none seemed to work.
- Would I need to get an ISP, and reload the bootloader?

Thank you for any advice in advance!
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6146
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The programmer only applies to burning the bootloader, not loading sketches.

Are you pressing reset before uploading the sketches?  As I recall, the Mini doesn't have a capacitor to enable auto-reset.
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, I have been resetting the board manually which seems to work, without the reset it gives a sync error.

Thank you.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just to clarify - when I mentioned the reset "seems to work" I meant without it it causes a sync error, when I do press the reset the tx/rx pins flicker, and after the bootload I get the "yikes invalid" msg. I tried this on three different mini modules.
Logged

Austin, TX
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6146
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The only other step I can think of is to burn the bootloader again. 
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thank you, I ordered the AVRISP MKII...I will try that when I receive it.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 11
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

In Arduino 1.0, try changing:

mini328.upload.protocol=stk500

to:

mini328.upload.protocol=arduino

in the boards.txt file.  Does that fix the problem?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes! I have same problem and your solution fix the problem! Thank you very match!
Logged

Boston, MA
Offline Offline
Full Member
***
Karma: 0
Posts: 129
Batteries? We don't need no steenking batteries!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
I also ran into this same problem when porting my own Arduino-derived project (Sanguino-based) from 0022 to 1.0 (same board = works in 0022, "Invalid device signature 0x000000" in 1.0), and the solution above seems to work for me.

@mellis, if you still happen to be watching this thread :-) - do you have any additional information as to why this works, what changed or what the underlying problem was/is? I'm hesitant to start distributing what seems like a "voodoo fix" with the project without any understanding of the underlying problem, or whether these ("stk500"/"arduino") definitions will flip again in 1.0001, etc. (@Coding Badly has a possible explanation in the thread linked above, but it's just a guess so far.)

Thanks!
Logged

Pages: [1]   Go Up
Jump to: