Pages: [1]   Go Down
Author Topic: Pin 10 is stuck HIGH  (Read 334 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My Arduino mega (ATmega1280) has port 10 stuck on HIGH.  When I changed the code to use pin 9 it all works fine.  Is this common?  I assume I must have once made a wiring mistake and somehow burnt it out.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 212
Posts: 13074
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
My Arduino mega (ATmega1280) has port 10 stuck on HIGH

How do you know?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

How do you know?

I tested it with a multi meter, set to DC volts.
Logged

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 212
Posts: 13074
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


After uploading an empty sketch to the board, you measure a stable 5 volts on pin 10?

Do you measure 5 volts after connecting a large value resistor (say 10K) between pin 10 and GND?
Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you remember to set the pin as an OUTPUT?
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Pages: [1]   Go Up
Jump to: