Pages: [1]   Go Down
Author Topic: Zigbee on XBee Series 1  (Read 2426 times)
0 Members and 1 Guest are viewing this topic.
Madrid
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino on the rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

as i posted long time ago here:
http://arduino.cc/forum/index.php/topic,39397.msg289213.html#msg289213

here you've got the 'forbidden copy' that gives an xbee series 1 the power to mesh

let's hack it!

* xbee_v1094.zip (269.04 KB - downloaded 44 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok,,

1) i extracted the files in the zip you've posted my question is

where exactly do i have to put them in the Digi folder?

there is a folder named: update , where are similar files..

2) and after i put them in the right folder the Zigbee capabilities are going to be available in the X-CTU software?

« Last Edit: February 23, 2012, 02:53:32 pm by billy1010 » Logged

Madrid
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino on the rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

1- first step, excuse me for my mistake uploading the wrong file  smiley-roll
2- download the file attached to this comment: xbee_v8x13_firmwarehack.zip
3- download the XCTU ver 5.1.0.0 from http://www.digi.com/support/productdetail?pid=3352&osvid=57&type=cabling
4- install it ,but answer No when it ask you to look for new updates
5- open xctu, go to Modem configuration
6- select your device in Modem: XB24 for normal series1 XBP24 for pro
7- notice that you have only the standard Function Set to choose (for the time being...  smiley-evil)
8- press Download new versions... and a new window will appear
9- press File... and select the new and right file uploaded here, then Ok, then Done
A- select your device in Modem: XB24 for normal series1 XBP24 for pro
B- now you have 4 more Function Set to choose, from 8013 to 8313  smiley-twist smiley-twist smiley-twist smiley-twist
C- remember it's just a official beta version without support and hard to get: http://www.digi.com/support/kbase/kbaseresultdetl?id=2182#Version 8.x.1.3


* xbee_v8x13_firmwarehack.zip (1114.14 KB - downloaded 40 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey again yorx.. thanks for the quick replies.. smiley

ok i followed your process

but when i press Write i get

"Getting modem type....OK
Programming modem...Lost communication with modem
Write Parameters...Failed"

my xbee is XB24 and firmware version: 1084

have you achieved to write it to your xbee?? smiley-roll

Thanks again mate!
Logged

Madrid
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino on the rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

in order to know if it's a problem of your module try to restore and write your actual version with different parameters
you can try also to follow the process with the first file i posted: xbee_v1094.zip
it just agree more modem files to your pc so there's no problem
i'll try to find some module to try but it will maybe take me some time smiley-small
post your results please
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

my module its ok.. i have downloaded X-CTU 5.2.7.5

and selected the correct version(1084) and it works fine, i can write or restore parameters fine  smiley-roll

with version X-CTU 5.1.0.0 i cannot speak to my module beacuse version 1084 is not offered.

if i update X-CTU 5.2.7.5 with both .zip files you attached recently i can see the Zigbee capabilities available in Function Set

but if i chose one of these option the version is different(8013,8113,8313,8213) and again i get the same error message:

Getting modem type....OK
Programming modem...Lost communication with modem
Write Parameters...Failed 

 smiley-eek
Logged

Madrid
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino on the rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ta the end i've found a working XB24 sooner than i thought, but there aren't good news  smiley-eek-blue
i've tried checking three differen XCTU versions, checking the Enable API and Always Update Firmware and doesn't work!  smiley-eek  smiley-sad-blue
googling about the version i've found the same info i founded 3 years ago
a web with files from a guy named Faludi that achieved it long time ago (when the beta version was released)
here it is: http://www.faludi.com/itp/XBee_ZigBee_Beta/
good luck mate, i'll tell you if i get it
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ufff i guess i am officialy stacked  smiley-confuse

ok bro thanks for the try..i will contact you if i find something..

see ya..
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

I was able to connect to connect to my xbee usb module by using X-CTU..
Then I have made a change of the XB24 model and use the the function XBEE 803.15.4 RS232 Power harvester.
Now I can not connect to the modem… any idee or settings I should use . change to get access with X-CTU again ?

Txs in advance, yann
Logged

Pages: [1]   Go Up
Jump to: