Pages: [1]   Go Down
Author Topic: 15m SPI Kabel- oder doch nur Temperaturproblem  (Read 817 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 11
Posts: 58
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,
ich habe ein Problem bei einer Funkstrecke. Seit ca. 2 Wochen verliere ich immer wieder Sendungen zwischen 2 Arduinos mit 2,4Ghz Transceivern. In den 6 Monaten davor hat es jedoch ohne Probleme funktioniert.

Das Austauschen der Transceiver hat leider keine Besserung gebracht. Die nrf24l01+ Transceiver senden jetzt bereits bis zu 15 mal. Trotzdem gehen immer wieder Sendungen verloren.

Die meisten Probleme traten bei Temperaturen unter -12°C (gemessen beim Transceiver) auf. Kann es sein dass diese Temperatur zu kalt für die Quarze ist?

Ein SPI Kabel von einem Mega zum Transceiver beträgt etwas über 15 Meter, ich fürchte dass das zu lang sein könnte. (Erklärt allerdings nicht warum es zuvor funktioniert hat)

Angenommen es ist die SPI Verbindung was wäre eine sinnvolle Alternative:

1.   Mehrere Max3232 Chips an beiden Seiten an die bestehenden Kabel
2.   Zusätzlicher Arduino zum Transceiver und Verbindung zum Mega über Uart


Und in dem Zusammenhang gleich noch eine Frage:
Welche Chips eignen sich zum Multiplexen von SPI?
Logged

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 258
Posts: 21497
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Wie willst Du SPI multiplexen????
Was willst Du mit der RS232  Schnittstelle machen?
Wieso hast Du 15m SPI und erst dann den Transcever?
Grüße Uwe
« Last Edit: February 23, 2012, 02:47:08 pm by uwefed » Logged

Offline Offline
Jr. Member
**
Karma: 11
Posts: 58
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

Wieso hast Du 15m SPI und erst dann den Transcever?
Der Arduino ist in einem Gebäude fix eingebaut. Ohne das Lange SPI Kabel, kein Empfang.

Wg RS232:
Habe mir gedacht die SPI Signale auf RS232 Niveau umzusetzen wg. Störungsempfindlichkeit. Bin ich damit auf dem Holzweg?


wg. Multiplexen:
Mit Multiplexen meine ich umschalten zwischen meheren SPI Geräten. Ich weiß schon dass das normalerweise nicht notwendig ist, allerdings stören manche Ethernet-Shields die SPI-Leitungen auch wenn sie nicht selected sind.

Logged

Forum Moderator
BZ (I)
Online Online
Brattain Member
*****
Karma: 258
Posts: 21497
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Versuch mal die Übertragungsgeschwindigkeut der SPI-Schnittstelle zu verringern
Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 11
Posts: 58
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

An das einfachste habe ich natürlich nicht gedacht. Danke, werd ich machen!

Trotzdem ev. eine Empfehlung zum SPI Multiplexen?
Logged

Pages: [1]   Go Up
Jump to: