Go Down

Topic: Made my own TwitterClient and I think it's better than the example one (Read 14 times) previous topic - next topic

kenneth87

hey JO3RI,

I've started a similar project that uses a freetronics etherTen board(basically a board similar and compatible with the arduino).

I hooked it up to a 20 by 4 LCD display and everything is going fine. I'm just stuck on coding with the board that is suppose to connect it to the internet to retrieve tweets from my twitter account. do i just run your code and edit what is necessary to get it up and running then edit it?

also how do i get the ip, mac address, subnet mask, gateway and dns? do i just leave it as it is and rely on dhcp or?

appreciate your help. Have a few books on arduino but need a little kick to get this up and running.

cheers!

JO3RI

Hi,

First just try the code as is, but manually change ip, mask, gw and dns (the code doesn't use DHCP). You should know this things from your own network.

Quote
byte ip[] =  { 192,168,1,10}; //change this
byte subnet[] = {255,255,255,0}; //change this
byte gateway[] = {192,168,1,1}; //change this
byte dns[] = {192,168,1,1}; //change this


ip: pick a free ip in your network
subnet: take the same one from your computer
gateway: take the same one from your computer
dns: take the same one from your computer

juest leave the mac address as is.

once this is running, you can continue to get the message on your LCD

kenneth87

Hi JO3RI,

I've made amendments to the program but i received this error.

'byte dns []' redeclared as different kind of symbol

could my version of Ethernet.h library be different?

i tried commenting the byte dns line but nothing showed up on the LCD.

Appreciate your advise!

cheers!

JO3RI

Hi again,

strange thing:

Quote
'byte dns []' redeclared as different kind of symbol


I just uploaded the code (you find in the very beginning of this topic), and uploaded it to my arduino ethernet and arduino IDE 1.0

guess what, it just works  :~

Did you try to use dhcp any way on top of my code? (it seems dns got declared more then once)

if you can't find the problem, just post your code here, and I'll cross check it.

JO3RI

Hi again.

This morning I tried Arduino IDE 1.0.1 and guess what ... yep:
Quote

'byte dns []' redeclared as different kind of symbol'


So, it must be something with Arduino IDE 1.0.1, but I don't know what. I'll try to figure it out, bur for now, you beter use Arduino IDE 1.0.0 http://arduino.googlecode.com/files/arduino-1.0-windows.zip

Go Up