Go Down

Topic: Upload Problems: avr-g++: CreateProcess: No such file or directory (Read 6771 times) previous topic - next topic

Jyosua

I followed the instructions for setting up my arduino Uno. Installed the drivers from the problem folder, selected the Uno and COM 3 port. But when I try to run the Blink test sketch, I get the following error:

avr-g++: CreateProcess: No such file or directory

Has anyone else encountered this problem? How can I get this to work? I redownloaded the files to see if that would fix it, but it has not. I'm running Windows 7 64-bit ultimate and using the 1.0 IDE.

Coding Badly


https://www.google.com/search?q=CreateProcess+site:arduino.cc
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1238257341

Jyosua

I already saw that thread. Tried adding #include "WProgram.h" but that didn't work. Running echo % GCC_EXEC_PREFIX% in the command prompt returns % GCC_EXEC_PREFIX% and the rest of the thread is over my head.

Coding Badly


Remove the space...

[font=Courier New]% GCC_EXEC_PREFIX%[/font]

Jyosua

Yep I just tried that. It now returns c:\progra~2\egcs\lib\gcc-lib\

I take it I'm supposed to remove that system variable somehow? How do I do this?

Edit: Found where to remove it. Trying again now.

Edit2: Yup, it works now. Well, that's interesting. I'm not sure how that variable had been set.

For those that find this thread later, do the following:

Open the Command Prompt
Type "echo %GCC_EXEC_PREFIX%" into it, without quotes of course.
If it returns a path of some sort, you'll need to remove it.
Press Start, and right click on computer.
Click properties, and then Advanced system settings, located on the left of the window that opens.
Click Environment Variables, and locate GCC_EXEC_PREFIX in the list near the bottom of the window. Select and delete it.
Restart. Uploading should work after restart.

WizenedEE

Quote

Press Start, and right click on computer.
Click properties, and then Advanced system settings, located on the left of the window that opens.
Click Environment Variables, and locate GCC_EXEC_PREFIX in the list near the bottom of the window. Select and delete it.

It's probably a lot easier to just type:
GCC_EXEC_PREFIX=
Quote

Restart. Uploading should work after restart.

restart what?

Skyviper

I am new to the arduino community and find that the posts are not good nor does the people answering the questions consider the time of others. I have been redirected so many times on this issue that one cannot determine write from wrong. Lets look professional and provide complete answers in a way that helps people.
Example:
Ans:
For IDE version(s) 1.x, these are the things you check to determine where the problem lies.
1...
2...
3...

If 1 fails do something.
If 2 fails do something
If 3 fails do something

If they all fail do something or contact Jane Doe at ....

Answering in this manor cuts down on the confusion. Thanks!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy