Pages: [1]   Go Down
Author Topic: [Risolto] Ei fu AtMega328p  (Read 1325 times)
0 Members and 1 Guest are viewing this topic.
Parma
Online Online
Edison Member
*
Karma: 21
Posts: 2387
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ei fu. Siccome immobile,
dato il mortal corto,
stette il package immemore
orbo di tanto spiro,
così percosso, attonito
il silicio al nunzio sta,
muta pensando all'ultima
ora dell'elettron fatale;

adattamento da il 5 Maggio di Alessandro Manzoni

In parole povere ragazzi ho costruito un Arduino StandAlone ed ho scoperto che la funzione beep del multimetro suona solamente quando la resistenza è praticamente zero, mi era sfuggito un corto di 700 ohm tra +VCC e GND, forse il 78L05 e certamente l'AtMega328p mi hanno lasciato.

Potete darmi qualche suggerimento per verificare al meglio i circuiti su millefori? Mi spiego, ho dei corti che sembra che vanno e vengono, per risolverli con il puntale del tester cerco di grattare via dei residui probabilmente di stagno tra le piste che fanno i falsi contatti ma questa soluzione non mi sembra molto "professionale".

Immergendo il tutto nell'alcol o in qualche altra sostanza per eliminare piccoli contatti risolverei qualcosa?

Ciao e grazie a tutti

PS: Vi è piaciuta la poesia?
« Last Edit: February 26, 2012, 05:40:58 pm by flz47655 » Logged

Deep south of Italy
Offline Offline
Faraday Member
**
Karma: 8
Posts: 2955
The quieter you become, the more you can hear
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

come fà l'alcol ad eliminare i piccoli contatti?
l'unica soluzione è fare delle buone saldature ed avere buone attrezzature.
una millefori ha un passo abbastanza largo, se fai dei corti con quella significa che probabilmente usi troppo stagno , oppure lo stagno che usi è troppo spesso.
Alla fine puoi guardarti le saldature con una lente e controllare con il tester quelle adiacenti sospette.
Logged

Monselice PD Italy
Offline Offline
Faraday Member
**
Karma: 26
Posts: 5500
фон Крыса
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mi aggrego a brain, per di più non è detto che il micro sia spacciato... può essere partito il solo regolatore.. bella poesia, molto NERD   smiley-twist smiley-twist smiley-twist
Logged

Se corri veloce come un fulmine, ti schianterai come un tuono.

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 569
Posts: 12576
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao flzmanzoni, come poeta plagiante sei di sicuro meglio che come elettronico autodidatta smiley-mr-green smiley-mr-green smiley-mr-green
Ma che saldatore e stagno usi per ottenere tutte le schifezze che dici di avere a fine lavoro? Potresti postare una foto della tua millefori lato saldature. 700 ohm non sono per niente un corto, e comunque è tutta corrente che scorre in questa parte di circuito e non nell'atmega, quindi bosognerebbe capire il vero problema qual era.
Non conosco metodi per ripulire le millefori dai cortocircuiti (ora non è una battuta, è inteso per ciò che dici tu, lo stagno in eccesso), se lo stagno è solo appoggiato (le classiche palline), una spruzzata di alcool isopropilico ed passata con uno spazzolino da denti fanno sparire ogni cosa, ma se hai inavvertitamente saldato due piazzole adiacenti e creato un corto non c'è scampo, devi sperare che il danno sia lieve.

mi ha anticipato un po' di gente, ma ormai ho scritto...
Logged

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 569
Posts: 12576
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Legacy  smiley-eek-blue, con tutto il rispetto e la stima che ho per te, mi sa che non è la scheda che "ha fumato"  smiley-mr-green smiley-mr-green smiley-mr-green
Logged

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Naples (IT)
Offline Offline
God Member
*****
Karma: 6
Posts: 714
Andrea E.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Chi e' stato? Voglio i nomi !

Hai così sparlato male della raspberry che forse forse..........
Logged

Arduino, MODs e DIY: blackstufflabs.com

Parma
Online Online
Edison Member
*
Karma: 21
Posts: 2387
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao a tutti,
Non mi smontate come elettronico autodidatta dai  smiley-cry

Ci sono rimasto malissimo dopo aver perso diverso tempo a capire se c'erano falsi contatti ho capito che il circuito non ha anomalie ed il contatto strano si verifica solamente con l'AtMega inserito!  smiley-eek

Se controllo col tester ARef e AGND trovo una resistenza di 50 ohm, fra A0 (pin 23) e A- (pin 22) una resistenza di 700 ohm, e misuro queste resistenze anche senza circuito ma tra i piedini del chip scollegato. Che il chip sia fritto?

Ad ogni modo il circuito sembra essere elettricamente senza falsi contatti, vi tengo aggiornati

@legacy: si vede che ieri non era giornata per fare schedine..
Logged

Parma
Online Online
Edison Member
*
Karma: 21
Posts: 2387
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ragazzi ha dell'impossibile ma è andata così:

Lo sketch di prova che avevo creato usava il pin 4 per accendere un led (il classico blink). Avevo scelto a caso questo led perchè nella mia millifori ho montato solo alcuni pin header femmina, gli altri mi devono arrivare dalla cina.

Per la prova avevo usato un AtMega preso "dal mucchio" che sfortunatamente ho scoperto ora essere un AtMega che scaldava assorbendo 150 mA invece dei 10-15mA canonici, ne avevo parlato tempo fa nel forum e avevo risolto sostituendolo da Arduino, l'avevo in qualche modo rotto però non l'avevo buttato ed in qualche modo era finito tra tra quelli buoni (guarda te che sfiga!).

Ora spinto dalla disperazione ho provato a cambiare pin e magicamente funziona! In pratica ho risolto due misteri, il chip scaldava perchè avevo rotto proprio il pin 4 tempo fa e il circuito su millifori invece... era saldato a meraviglia, i finti corti che come giustamente diceva Menniti non erano corti perchè da 700 ohm, erano la normale resistenza tra pin del chip.

Ciao e grazie a tutti
Logged

0
Online Online
Faraday Member
**
Karma: 47
Posts: 5909
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

grazie del feedback e complimenti per la poesia  smiley
Logged

- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 332
Posts: 22813
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Metti [Risolto] nel titolo, va'.. meglio così  smiley-wink
Logged


Pages: [1]   Go Up
Jump to: