Pages: 1 [2]   Go Down
Author Topic: [SOLVED] IDE crashes without notice  (Read 3425 times)
0 Members and 1 Guest are viewing this topic.
the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 159
Posts: 2916
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
"C:\arduino\arduino-1.0\java\bin\java.exe" -verbose -Xms128m -Xmx128m -classpath "lib;C:\arduino\arduino-1.0\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.jar;lib\RXTXcomm.jar" processing.app.Base

You will see a bunch of information in the console window. Hopefully this will help narrow down the cause of the problem.

The following doesn't help with the startup problem, but is the typical way of displaying all that info in
the console window. Once the IDE has started [assuming you can get there], go to "File > Preferences",
and edit the preferences.txt file to include the line "build.verbose=true". You have to close the IDE
before saving the file, else the IDE will overwrite it.

This apparently has the same effect as your -verbose parameter above. This is how I found out where
the IDE stores all the build/console/untitled folders that never get deleted, and also that "core.a" is
never deleted from buildxxxxxxx.tmp on my machine that hangs when the IDE closes.

I can see the problems, but still have NO WAY to fix them.
 

Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That command is the command that is issued by the arduino.exe application to launch the IDE in the java environment. The -verbose switch is added to hopefully see detailed information about the java environment as it is launching the IDE.

Launching the IDE with this command does not have anything to do with the preferences.txt or how the IDE invokes the compiler.

Attached is the verbose output from the command that I captured on my machine.

* out.txt (184.07 KB - downloaded 28 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I see...

In my particular case, launching the arduino.exe itself doesn't starts the IDE (it crashes after splash screen).
On the other hand, launching your provided java line command, the IDE works like a charm. It is stable and closes perfectly.

I made a .bat file to launch the IDE as a workaround for my particular case.

Weird, isn't it?

Thanks again to all of you.

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 5
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same issue.  Resolved it by downloading Java v 7 and installing the desktop version:
http://java.com/en/download/chrome.jsp?locale=en

Then copied the bin & lib folders from the java install (c:\program files (x86\java on Win7 64) to overwrite the java\bin and java\lib files in arduino's java subdirectory.  Seems the install package could use an update.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Since this is the longest running and most USEFUL thread on debugging Arduino startup problems on Windows, I'm adding my unique solution to my own problem. THANK YOU Louis for posting how to launch the IDE with verbose output! That was how I found my error.

Here was the command I ran and the error I got:
Code:
C:\arduino>"C:\arduino\java\bin\java.exe" -verbose -Xms128m -Xmx128m -classpath
"lib;C:\arduino\java\lib\tools.jar;lib\pde.jar;lib\core.jar;lib\jna.jar;lib\ecj.
jar;lib\RXTXcomm.jar" processing.app.Base > log.log

Exception in thread "main" java.awt.AWTError: Assistive Technology not found: co
m.sun.java.accessibility.AccessBridge
        at java.awt.Toolkit.loadAssistiveTechnologies(Unknown Source)
        at java.awt.Toolkit.getDefaultToolkit(Unknown Source)
        at processing.core.PApplet.<clinit>(Unknown Source)
        at processing.app.Preferences.save(Preferences.java:812)
        at processing.app.Preferences.init(Preferences.java:264)
        at processing.app.Base.main(Base.java:113)

A little researching led to this solution: Delete "C:\Users\%USERNAME%\.accessibility.properties" ?!

This was because I had previously used an old version of a program called Sikuli Script that required installing an old version of Java and used the Java AccessBridge in order to do some things. Apparently this file got installed, and now the default settings for Java programs were to load the AccessBridge. Maybe it was installed wrong, or just incompatible with the Java that comes with Arduino, or I DON'T KNOW but after renaming the file, Arduino IDE could launch again! Hopefully my problem isn't COMPLETELY unique to me, and some other soul on the Internet will find this solution useful.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This was very helpful, thanks.
Logged

Pages: 1 [2]   Go Up
Jump to: