Pages: 1 [2]   Go Down
Author Topic: LM335  (Read 2203 times)
0 Members and 1 Guest are viewing this topic.
Israel
Offline Offline
Jr. Member
**
Karma: 0
Posts: 84
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Please tell what you wanted to add.

Thanks.
Logged

Offline Offline
Edison Member
*
Karma: 56
Posts: 2184
Now, More Than Ever
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You should still get "5V" even using USB. 
At least, I do with my "2009".
But, +V_usb has a wide range, too, so that could throw your readings off.  Is that it?
Logged

"Hello, I must be going..."
"You gotta fight -- for your right -- to party!"
Don't react - Read.
"Who is like unto the beast? who is able to make war with him?"

Israel
Offline Offline
Jr. Member
**
Karma: 0
Posts: 84
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here I add some results:

Only USB - Vcc = 5V
Code:
Celsius: 41.79
Kelvin: 314.94

Celsius: 41.79
Kelvin: 314.94

Celsius: 41.79
Kelvin: 314.94

Only USB - Vcc = 3.3V
Code:
Celsius: 23.24
Kelvin: 296.39

Celsius: 23.24
Kelvin: 296.39

Celsius: 23.24
Kelvin: 296.39

With adopter - Vcc = 5V
Code:
Celsius: 23.24
Kelvin: 296.39

Celsius: 23.24
Kelvin: 296.39

Celsius: 23.24
Kelvin: 296.39

With Adopter - Vcc = 3.3V
Code:
Celsius: 3.22
Kelvin: 276.37

Celsius: 3.22
Kelvin: 276.37

Celsius: 3.22
Kelvin: 276.37

Temp reading in case when Arduino was connected through USB only and Vcc = 3.3V is exactly equal to Arduino plugged in with adopter and Vcc = 5 V.
Strange, isn't it?
Logged

Pages: 1 [2]   Go Up
Jump to: