Go Down

Topic: cannot upload a sketch to Arduino YUN [SOLVED] (Read 245 times) previous topic - next topic

bartdewit

Jan 09, 2015, 06:56 pm Last Edit: Jan 12, 2015, 09:23 am by Nick Gammon
Hello,

I bought my Arduino YUN today and some basic sketches worked perfectly.

Unfortunately I cannot upload sketches anymore.

I got this error:
Sketch uses 4.744 bytes (16%) of program storage space. Maximum is 28.672 bytes.
Global variables use 151 bytes (5%) of dynamic memory, leaving 2.409 bytes for local variables. Maximum is 2.560 bytes.
avrdude: AVR device not responding
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.


When my YUN is started, these LEDs are on:
yellow RX
red L13
green ON
white USB

I upload my sketches over WIFI


WIFI and linux-chip do work, i can connect to the website, and can connect to the LINUX-chip with SSH - putty

I've tried to reset WIFI, 'YUN RST' and the 32u4, but that didn't solve the problem

Can somebody help me ? many thanks !

bartdewit

Solved: went back to the shop, 32u4 was broken, got a new one.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy