Pages: 1 2 [3] 4 5   Go Down
Author Topic: Missing digital signature for driver on Windows 8  (Read 146516 times)
0 Members and 6 Guests are viewing this topic.
Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This workaround is for Win8 x64.
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 48
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have had a few requests to add other versions of the Arduino boards, so I created a new version of the arduino.inf and arduino.cat files.
This version contains all the of the boards in the 1.0 IDE in one file.

Thanks for your work Louis! I've successfully installed the driver for the Arduino Uno on Windows 8 RTM (64 bit). But I recently bought an Arduino Ethernet (not the shield) and an Arduino USBSerial adapter, which I can't get installed. Should your files work for this combination too?

Additionally, Windows 8 is going to launch on October 26 for the general audience. Does anyone has an idea if the drivers are getting signed? Or do we need to keep working with this work-around?

Many thanks!
J
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you use the steps outlined here:

http://arduino.cc/forum/index.php/topic,94651.msg727588.html#msg727588

You can use the original .inf files included with 1.0.1.

Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 48
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If you use the steps outlined here:

http://arduino.cc/forum/index.php/topic,94651.msg727588.html#msg727588

You can use the original .inf files included with 1.0.1.



Thanks Louis, I found this post already (and applied the steps successfully). But from an "end-user" perspective, having to go through these steps is quite difficult and tedious. :-( You know if the goal is to have the drivers signed properly so the installation is smooth?

Thanks again,
Jan
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same here thanks a ton!
Logged

Seattle, Washington
Offline Offline
Newbie
*
Karma: 0
Posts: 2
- AustinWoehrle.net
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you use the steps outlined here:

http://arduino.cc/forum/index.php/topic,94651.msg727588.html#msg727588

You can use the original .inf files included with 1.0.1.



When I try to install, I get the message "Windows was unable to install your Unknown Device"
But it finds the folder that the driver is in automatically.

Any suggestions?
Thanks!
Logged

-New to Arduino 10/29/2012

- AustinWoehrle.net

Denmark
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Jubiiii it worked.

Perhaps a Little trickiy, but it doesen't matter.
I Wonder why I didn't have  the same trouble with my FTDI.
Never mind.

Best regards

Pjotr
Logged

Grand Island, New York, USA
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks Louis - your strategy worked like a charm. Hopefully the Arduino team can add that driver digital signature before too many boards are sold.
Cheers, Jim Lynch
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Fellas, i've tried everything. 2 different arduino uno boards, 2 different computers (Win7x64 and Win8x64), a dozen of goddamn usb cables, all kinds of drivers (including the ones by eried), USB 2.0 as well as 3.0 - this bitch still giving me "device cannot start error 10". Played around with com ports, baud rates and whatnot. Driver is getting installed and and device appears as Arduino Uno in device manager but it DOESNT WANNA START. My condition went beyond frustration - it's despair now. What should i do?? Is there a one 10000% working way??? Both boards seem to be working properly (green LED on and orange flashes sometimes). Should i get a different brand of board (mines both are OSEPP, Uno R3 Plus)? Should i run XP from a USB and try to work on it..? I need a definite answer please...
Logged

Austin, TX
Offline Offline
God Member
*****
Karma: 12
Posts: 524
carpe diem
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

noxep,

The OSEPP boards are not exactly the same as Arduino UNO boards. You can't use the Arduino supplied driver .inf files with those boards.

The OSEPP boards use the FTDI chips for USB/Serial communication.
You can get the latest FTDI drivers from this location:
http://www.ftdichip.com/Drivers/VCP.htm
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Louis, thanks a lot man!I got the latest drivers and now everything is working fine:)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for sharing!  I'm trying to access this menu using Windows 8 Release Preview on my Samsung 7 Slate.  When I arrive at the screen to select "Disable Driver Signature Enforcement", nothing happens.  My USB keyboard isn't registering, is there something I'm missing re: how to access this menu item?  Thanks in advance for your help!

Hey, The same thing is happening to me also with the 7 Slate.  I guess it's a hardware issue of some sort.  I even tried using different keyboards and got nowhere.  Unless there is a way to do it through the command prompt, then we're in trouble.
Logged

Kraków
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Liber
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

My Arduino UNO R2 works great in Windows 8 Pro.

Thanks a lot, for all !
 
My steps:

0)Install IDE and change driver port as shows: http://arduino.cc/en/Guide/UnoDriversWindowsXP
1)Restart Win8 then run pressing F8 for "Disable Driver Signature " like here http://arduino.cc/forum/index.php/topic,94651.msg727588.html#msg727588
2)Log out from any user account (even if administrator privvileges etc.) and log as main Administrator account (create new or Turn on from Win 8 Control Panel if Admin disabled)
2)Install this:  http://arduino.cc/forum/index.php?topic=118440.0
3)Connect to other USB port.
4)Run as admin then rejoyce  smiley-grin

I,m using simple USB white cable from printer.
Official Arduino 1.0.2 IDE start now properly.

My first day with Arduino smiley-cool
Logged

Värmland, Sweden
Offline Offline
Sr. Member
****
Karma: 9
Posts: 262
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

2)Log out from any user account (even if administrator privvileges etc.) and log as main Administrator account (create new or Turn on from Win 8 Control Panel if Admin disabled)

Why did you have to enable the Administrator account?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks!!!!!!!! for the information!!!
Logged

Pages: 1 2 [3] 4 5   Go Up
Jump to: