Pages: [1]   Go Down
Author Topic: randomly (not) working serial.read  (Read 422 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I have made an simple visual basic program wich should turn my amplifier on and off.. but also return wether its on or off when i send "3"...

if i send 1 the amp goes on & set pinstat = 1
if i send 2 the amp turns off & set pinstat = 0
if i send 3 arduino does a serial.write(pinstat);

sometimes it just does not return anything on 3...

Any idea's? i have no access to the code right now...


Greetings,
Marco Stuurman
Logged

Seattle, WA USA
Online Online
Brattain Member
*****
Karma: 613
Posts: 49249
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
i have no access to the code right now...
We can wait until you do. No hurry.
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 217
Posts: 13702
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
sometimes it just does not return anything on 3... ideas?
Arduino off?
Maybe you should have a second arduino to check if the first Arduino is on? smiley-wink
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes it is on, and i found out, i was asking the value the fast after eachother
Logged

Pages: [1]   Go Up
Jump to: