Pages: [1]   Go Down
Author Topic: Upload Problems: avr-g++: CreateProcess: No such file or directory  (Read 4134 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I followed the instructions for setting up my arduino Uno. Installed the drivers from the problem folder, selected the Uno and COM 3 port. But when I try to run the Blink test sketch, I get the following error:

avr-g++: CreateProcess: No such file or directory

Has anyone else encountered this problem? How can I get this to work? I redownloaded the files to see if that would fix it, but it has not. I'm running Windows 7 64-bit ultimate and using the 1.0 IDE.
« Last Edit: February 23, 2012, 09:33:31 pm by Jyosua » Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 200
Posts: 12777
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


https://www.google.com/search?q=CreateProcess+site:arduino.cc
http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1238257341
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I already saw that thread. Tried adding #include "WProgram.h" but that didn't work. Running echo % GCC_EXEC_PREFIX% in the command prompt returns % GCC_EXEC_PREFIX% and the rest of the thread is over my head.
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 200
Posts: 12777
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Remove the space...

% GCC_EXEC_PREFIX%
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yep I just tried that. It now returns c:\progra~2\egcs\lib\gcc-lib\

I take it I'm supposed to remove that system variable somehow? How do I do this?

Edit: Found where to remove it. Trying again now.

Edit2: Yup, it works now. Well, that's interesting. I'm not sure how that variable had been set.

For those that find this thread later, do the following:

Open the Command Prompt
Type "echo %GCC_EXEC_PREFIX%" into it, without quotes of course.
If it returns a path of some sort, you'll need to remove it.
Press Start, and right click on computer.
Click properties, and then Advanced system settings, located on the left of the window that opens.
Click Environment Variables, and locate GCC_EXEC_PREFIX in the list near the bottom of the window. Select and delete it.
Restart. Uploading should work after restart.
« Last Edit: February 23, 2012, 09:48:16 pm by Jyosua » Logged

Offline Offline
Edison Member
*
Karma: 19
Posts: 1041
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Press Start, and right click on computer.
Click properties, and then Advanced system settings, located on the left of the window that opens.
Click Environment Variables, and locate GCC_EXEC_PREFIX in the list near the bottom of the window. Select and delete it.
It's probably a lot easier to just type:
GCC_EXEC_PREFIX=
Quote
Restart. Uploading should work after restart.
restart what?
Logged

Pages: [1]   Go Up
Jump to: