Go Down

Topic: arduino uno porta non vista dal software e vista da pc (RISOLTO ) (Read 1 time) previous topic - next topic

satchmo

Mar 07, 2012, 05:39 am Last Edit: Mar 08, 2012, 07:22 am by satchmo Reason: 1
ciao a tutti, ho questo problema ultimamente;:
se collego arduino uno alla presa usb viene visto dalle risorse del computer in com 8 , ma se faccio partire il software ARDUINO 1.0 oppure  0.22 e chiedo di vedere le porte disponibili  ho 3, 4, 5 .
sono con windows , su un altro pc lo vede , anche se un pò lento , provato con altro arduino uno , idem ..qualcuno ha avuto questo problema?
grazie in anticipo .
CArlo .

uwefed

Hai installato il driver? Win 7 non lo fa in automatico.
istruzioni: http://arduino.cc/en/Guide/Windows
Ciao Uwe

Testato

win7 lo fa in automatico, almeno a me, ho la versione 64bit
e cmq se nelle com vede arduinoUNO su com8 vuol dire che il driver e' ok.

prova cmq a ricaricarlo, fai anche un aggiornamento del java su java.com
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

satchmo

Ciao Uwefed ciao Testato , grazie , ho risolto ,prima ho provato ad aggiornare drivers e java,( che nn fa mai male :-) )
ma il problema restava , poi ho visto che nelle proprietà dal pannello di controllo era sì vista arduino nella com 8 però nello stato periferica
era scritto:
Impossibile avviare il dispositivo hardware. Le informazioni di configurazione nel Registro di sistema sono incomplete o danneggiate. (Codice 19) .
Per qualche oscuro motivo il problema era nel registro...
Disintallato driver e software del driver, reinstallato come da istruzioni uwefed (bisogna indicare proprio la cartella esatta che contiene il driver , non vuole saperne di sottocartelle il mio pc..) e funziona di nuovo ..
Vi ringrazio dell'attenzione,ciao  !

astrobeed


Disintallato driver e software del driver, reinstallato come da istruzioni uwefed (bisogna indicare proprio la cartella esatta che contiene il driver , non vuole saperne di sottocartelle il mio pc..) e funziona di nuovo ..
Vi ringrazio dell'attenzione,ciao  !


Se non mi ricordo male è pure scritto nella sezione hardware del sito principale, in tutti i casi Arduino, tutte le versioni, deve sempre essere installato utilizzando i suoi driver, posti nella relativa cartella, e mai tramite installazione automatica del sistema operativo, vale per tutte le versioni di Windows.
Usare il GOTO in C è ammettere la propria sconfitta come programmatore

satchmo

vero,solo pensavo bastasse indicare la cartella arduino 1.0 nella schermata ricerca drivers , invece bisogna dargli l'indirizzo della sottocartella drivers sennò non lo vede .
Non lo sapevo ora lo so  :)


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy