Go Down

Topic: Unable to add library (Read 406 times) previous topic - next topic

perrien

So I'm still a relative noob to Arduino but have been programming on the Mac for quite a while.

I'm trying to add a custom library to my Arduino project and just cannot get it to add. I'm following the tutorial:
http://arduino.cc/en/Hacking/LibraryTutorial
And even downloading that Morse library and it just will not show in the menu.
I created and saved a test sketch, downloaded the Morse, Sow Sketch folder, added a "libraries" folder and put Morse in it. Quit and reopen the software, Sketch - Import Library, nothing new. Any tips?

Running Arduino 1.0 on Mac OS 10.7.3. Tested in a new user, same problem.

kd7eir

Did you extract the Morse folder from the zip file, then copy the Morse folder to the Libraries folder?

My sketch folder is Documents -> Arduino.  Then I have Libraries, so the the full path is Documents -> Arduino -> Libraries -> Morse.

Is that what yours looks like?




perrien


My sketch folder is Documents -> Arduino.  Then I have Libraries, so the the full path is Documents -> Arduino -> Libraries -> Morse.

Is that what yours looks like?


It does now, and it works. When the tutorial said to go to the sketch folder, I figured Show Sketch Folder would get me to the right place. It actually dropped me into the sketch for the particular project.

Many thanks for the help.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy