Go Down

Topic: Sketch Uploading: USB to TTL Serial Converter (Read 7592 times) previous topic - next topic


Erni

#16
Apr 04, 2012, 05:41 pm Last Edit: Apr 04, 2012, 05:43 pm by Erni Reason: 1
First of all i would fix the driver problem.
You can do a search for cp2102 drivers, this came up fx.:

http://www.pololu.com/docs/0J7

When your driver is OK you could try the Loop-back-test
http://arduino.cc/forum/index.php/topic,73748.0.html

If this is OK, you know that your device is working

And just a note: the connections atleast on my cp2102 is: tx->tx rx-->rx

If all this is OK try uploading to the Arduino, and if it fails, try pressing reset when the message : Sketch size ...  appear in the serial monitor

jimbo8098

I have tried those drivers too but had the same issue. I have now soldered header pins accross the arduino's connection ports and can get a good connection using this but it is still giving the out of sync error. Glossing over the error , I powered up the arduino just to see if it uploaded but it didn't run the test I uploaded (blink test) I think the pin on 13 is synced up with the green LED on the board and that was flashing along with the LED I connected to it.

jimbo8098

Looks like the green LED on the board is connected to pin 13 already which may say that the sketch uploaded , however , I tried changing it to pin 9 but the LED wouldn't flash. Green LED was still flashing though.

Erni


jimbo8098

Ah , meant to say earlier. Yes I did at one point have the loopback working but it has since stopped working. I was able to receive callbacks from arduino after soldering the pins but I tried again later on in the day and found that it wouldn't work. Still seems like a funky connection but I can't imagine where. When I am uploading sketches everything is completely still now since it is breaboard mounted.

the ftdi is directly connected to the breadboard and , via jumper leads , onto the correct lines on the breadboard as per the diagrams. The arduino gets the signal through its own header pins now.

jimbo8098

I was looking through the forum when I spotted this thread:

http://arduino.cc/forum/index.php/topic,71752.msg762168.htm

He is using the same FTDI board as me so I am just interested as to why his works and mine dosent. The only difference I can see is that he is using a cap on rst. I was under the impression that the duino had a 0.1mfd cap on RST but there are 2 RST pins on the board. so it got me thinking , what if the pin I have been using all along is the one that dosent have the cap on it?

So I'm going to try that later this week when I can get down to maplin as the web isnt too great for small components like caps.

jimbo8098

ok added the capacitor and was able to upload a sketch but , interestingly , wasnt able to use the serial monitor... wierd... but as long as i can upload sketches , I'm not too bothered :)

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy