Go Down

Topic: Most peculiar thing about MEGA2560 that YOU WILL ALL WANT TO READ!!!! (Read 3174 times) previous topic - next topic


Actually to some of you its probably happened already. I just thought I'd put that as the subject so someone might read it. ;)
I have a Macbook Pro 15". I recently got an Arduino Mega2560 from China from a company called SAINSMART. I have been using the Duemilanove with the MAC succesfully but when cofigured and tried to upload to the MEGA it wouldn't upload ( not even the blink sketch)  and I kept getting timeout messages (STK500). There is a message on this board somewhere about that. I tried allsorts to get it working but couldn't.
I am also using Parallels for MAC running a version of Windows XP which works really well considering it is a Crack. I though as a resort I would try downloading the WINDOWS Arduino IDE. Version 1.0.
After running parallels, plugging in the Arduino Mega to a USB HUB connected to the MAC the new hardware detected came up and I installed the drivers as requested.
When I ran the Arduino program, configured it to MEGA and set a serial of COM3, IT WORKED!?!?!?!?!?!?!
I am of course delighted. The serial port was responding with a simple program as well. So as far as I know I can use it in the windows environment.
But how come it is working on a Windows Emulator running on the MAC but not on the MAC itself????
Answers and enquiries on a postcard to this forum please.  :)
Smooberry Dooberry.


My Mega2560 works just fine on my Mac with Lion.

Take a look here : http://arduino.cc/hu/Guide/MacOSX particularly sections 4 and 8, and see if that helps.


Hi and thanks for the message.
I'm certain the set up is correct....
Mega configured to serial: ttyUSBmodemfd141
Board configured to megaadk/2560
In network preferences, the grey box with found arduino mega came up and I clicked on apply. Now in network preferences I have a network phone sign at the side but with arduino mega :"not connected" 
What else could it be????
Smooberry Dooberry.


What else could it be????

Oh I don't know ... maybe its just cos its a Mac? :D

If it's working on windows and the emu that would say to me the installation of arduino software got currupt or perhaps your version of OSX is not supported. I'm not sure what the arduino uploader is designed in as I haven't even used it yet , but if it is supposed to run on all oses , it may be a java app? Then again I don't know if Java even provides that kind of functionality and I doubt it. In either case , maybe a java update will help?


The ATmega2560 has memory too large for the STK500(v1) protocol.  When you select the board "Arduino Mega 2560 or Mega ADK" it uses the stk500v2 protocol.  Are you sure you selected the Mega?
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp


Hi. Thanks for the reply.
Ok, theboard is definitely set to mega2560/adk setting.
the lights come on.
The complaint list comes up with:
And it keeps coming.
But the sketch doesnt upload :(
Does it mean arduino uploader is using stk500 v1???
Pls help? !?
Smooberry Dooberry.


Go here: /Users/<USERNAME>/Library/Arduino/preferences.txt, delete the preferences file, reboot, and try again.


Hi! OK, tried it. deleted preferences/arduino/preferences file.
Rebooted ( shut down.)
Restarted, ran Arduino, tried to upload sketch and.....

No luck.
Same problem....
Would it be worth trying to re burn the bootloader????
If so, ( ???)
I can still upload with the PC emulator ( parallels ) though....
But I want to use my MAC for Arduino.
Smooberry Dooberry.


There is nothing wrong with the bootloader since it works in the Parallels install of Windows.

Create a new user on the Mac, install the Arduino IDE in that account, and try uploading. 
This will tell you if the problem is related to the original user profile, or if it's a system-wide issue.

Also, the Mac can be particular regarding which usb port you are using.  Are you connecting to a port
on the keyboard, or on the CPU itself?


Its a laptop. Ive tried connecting to both the hub and the laptop itself with the same result...ive tried reinstalling the ide as well!
Smooberry Dooberry.


Ill try it with a new user as suggestd.thanks. in the meantime though, in my desperation i think ive overwritten the bootloader with a dfu bootloader. Now i need to work out how to burn the original back!!! This is turning into a bad dream. An embarrasing one...........
Smooberry Dooberry.


Thanks KD7. I managed to re burn my firmware back usinf DFU programmer and some bizarre settings so am now back where I started. As for trying a new user, I tried and still get the same result. Any more suggestions or should I admit defeat??) a little voice in the back of my mind says no and I agree with it(..)(

Smooberry Dooberry.


Is your system up to date on all updates?  There were some updates recently, including an EFI update.  You can also try resetting the SMC http://support.apple.com/kb/HT3964
Here is some info on USB troubleshooting: http://support.apple.com/kb/HT1151

The fact that it did not work in the new user account would normally indicate that it's a system-wide issue.  However, the fact that it works in the Parallels install throws a kink into that.
It's a bit of a long shot, but you could also try resetting disk permissions: http://support.apple.com/kb/HT1452

Go Up