Pages: [1]   Go Down
Author Topic: 1284p bootloader problem with serial?  (Read 488 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 29
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, in my project ATMEGA 1284p processor with display touchshield slide  , rtc, sd and some sensor when i upload sketch witch avr programmer all it's ok and work fine but when i try to use boot loader Mighty optiboot 16 mhz bootloader when i upload sketch the serial port don't respond? and arduino ide 1.0 dump this errors:

Code:
processing.app.SerialException: Error opening serial port '/dev/ttyUSB0'.
at processing.app.Serial.<init>(Serial.java:146)
at processing.app.Serial.<init>(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:75)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:88)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:66)
at processing.app.Sketch.upload(Sketch.java:1664)
at processing.app.Sketch.exportApplet(Sketch.java:1624)
at processing.app.Sketch.exportApplet(Sketch.java:1578)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2314)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2323)
at java.lang.Thread.run(Thread.java:679)
Caused by: gnu.io.UnsupportedCommOperationException: Invalid Parameter
at gnu.io.RXTXPort.setSerialPortParams(RXTXPort.java:171)
at processing.app.Serial.<init>(Serial.java:136)
... 10 more
processing.app.debug.RunnerException: Error opening serial port '/dev/ttyUSB0'.
at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:99)
at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:88)
at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:66)
at processing.app.Sketch.upload(Sketch.java:1664)
at processing.app.Sketch.exportApplet(Sketch.java:1624)
at processing.app.Sketch.exportApplet(Sketch.java:1578)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2314)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2323)
at java.lang.Thread.run(Thread.java:679)

How i can solve this issue? Thank

Marco
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 106
Posts: 6378
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
processing.app.SerialException: Error opening serial port '/dev/ttyUSB0'.
This is a PC-side issue; probably you have the wrong serial port specified.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 29
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

mmm i don't think if i try with arduino uno all it working fine....
how i can debug it?
Logged

Pages: [1]   Go Up
Jump to: