Go Down

Topic: trying to install arduino 1.0 on a fresh install of ubuntu 11.10 (Read 1 time) previous topic - next topic


I cannot find ANY way to do this.

the guides in the arduino instructions are outdated and none of the software they tell you to use is here anymore.

please help! The software center just gives me version 2200!!!


when i double click the arduino file in the arduino1.0 folder - nothing happens.


That is true if you use the icon in "Dash home". I found it is best to install the v0022 from the repository first! That way you get all the avr toolchain upgrades from the Ubuntu repository too.

Then download the Linux version of 1.0 from the Arduino website. Unpack it in a local directory. In that directory you will find a arduino shell script. Run it and you get v1.0.

You can still run v0022 by selecting the icon on the "Dash home" if you want.

I'm running three versions now:
v1.0.1 rc1

When I double-click the arduino shell script, I get a popup screen asking me what I want to do with the script. I select "Run". It takes several seconds to boot up. You don't get that prompt?


hey! thanks for the reply. Yeah I installed 0022 from the software center. then I downloaded the 1.0 version and installed to my home directory (tried it on desktop too).

I double click the arudino script and the pop-up happens and i click "run"

I waited for a long time and nothing happened at all. This is so frustrating. I am trying to set up this laptop as just my electronics laptop with a light OS.


Mar 21, 2012, 11:49 pm Last Edit: Mar 22, 2012, 12:09 am by SurferTim Reason: 1
I'm running all these versions on an old IBM Thinkpad. It takes about 15 seconds to start the IDE on mine.

edit: Try selecting "Run in terminal" at the prompt. See if the terminal window will show you what is wrong. Mine throws some Gtk warnings, then shows
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7

and the IDE pops up.


thanks again for helping me out.

it still does not work. when I run in terminal this is what it shows me;

Code: [Select]
java.lang.UnsatisfiedLinkError: /home/elijahlucian/Desktop/Arduino/lib/librxtxSerial.so: /home/elijahlucian/Desktop/Arduino/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch) thrown while loading gnu.io.RXTXCommDriver
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/elijahlucian/Desktop/Arduino/lib/librxtxSerial.so: /home/elijahlucian/Desktop/Arduino/lib/librxtxSerial.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1675)
at java.lang.Runtime.loadLibrary0(Runtime.java:840)
at java.lang.System.loadLibrary(System.java:1047)
at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
at processing.app.Editor.populateSerialMenu(Editor.java:969)
at processing.app.Editor.buildToolsMenu(Editor.java:697)
at processing.app.Editor.buildMenuBar(Editor.java:482)
at processing.app.Editor.<init>(Editor.java:204)
at processing.app.Base.handleOpen(Base.java:700)
at processing.app.Base.handleOpen(Base.java:665)
at processing.app.Base.handleNew(Base.java:561)
at processing.app.Base.<init>(Base.java:301)
at processing.app.Base.main(Base.java:190)

after which it doesn't do anything. the terminal stays open.


Are you using a 32 bit version of Ubuntu? And downloading the 32 bit Linux version of the IDE?


im 99% sure I'm running the 32-bit linux and I am positive I downloaded the 32-bit arduino 1.0


wow... ok. apparently I installed the 64-bit OS! argh. I didnt mean to do that. I only have 4gb ram...

ah well anyways. thanks for all the help folks! I really really appreciate it.

Downloaded the 64 bit linux 1.0 and it works instantly *facepalm*

Go Up