Go Down

Topic: Can't switch to DFU on Uno R3 (Read 1 time) previous topic - next topic


Mar 22, 2012, 06:41 pm Last Edit: Mar 22, 2012, 10:47 pm by xico Reason: 1
Dear Arduino community,

I just received my first Arduino device, an Arduino UNO R3. I connected it to a computer using different USB cables, and each time the power LED switched on, and the orange LED started blinking regularly (after an initial boot process). Unfortunately, nothing appears on the computer, Windows detect no new device (even after installing the virtual COM drivers), and Linux shows nothing on lsusb, dmesg, or /var/log. This was tested on different computers too.

After searching a bit in the forums, a possible explanation might be that the firmware might be corrupted. Thus, I am trying to upload a new driver to the Uno. I installed dfu-programmer, after applying the atmega16u2 patch, but it simply says: dfu-programmer: no device present. I assume that this might be because the device is not in DFU mode. However, I cannot find a correct way to switch to DFU. I tried connecting together the RESET and GND on the ISP (assuming they are the two closer to the USB), but nothing happens at all (I tried for various durations around 1 second). Pressing the reset button does reboot the current sketch (but obviously not switch to DFU).

So, should I just return the device to seller or is there something else you could suggest?

Thanks in advance.


Sound's like a dud. Something is wrong with the USB hardware or the 16u2. One final thing to try would be to program the 16u2 via the ISP header, otherwise send it back for replacement.


Some people have had trouble with DFU if they use hubs, or USB3. So make sure you are connecting directly to a USB2 or USB1 port on the computer. And if ever you try to reset the Arduino by unplugging it from the USB port and plugging it back in, always make sure you wait 10 seconds between unplugging and plugging in. If you plug it in too quickly after unplugging the USB chip can get confused. It can take another 10 seconds after plugging in for Linux to detect it.

If you do all that and there's still nothing showing on dmesg then it's probably faulty.
Due VGA library - http://arduino.cc/forum/index.php/topic,150517.0.html

Go Up