Pages: [1]   Go Down
Author Topic: AVRProjectIDE with version of Arduino 1.0  (Read 1050 times)
0 Members and 1 Guest are viewing this topic.
Greece
Offline Offline
Full Member
***
Karma: 2
Posts: 175
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi to all,

Can some one has success using the perfect editor AVRProjectIDE with the new Arduino 1.0
I have go to Tools --> Editor Settings --> and i select for the Core files: C:\arduino-1.0\hardware\arduino\cores\arduino

and for the libraries:  C:\arduino-1.0\libraries

but when i compile i got errors the first of that is:
file                   line  Where           Message
wiring_digital.c   138  'digitalWrite'  undefined reference to 'port_to_output_PGM'

........


Can some one please help me ?

Thank you in advance.
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 212
Posts: 8966
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you include Arduino.h like the Arduinbo IDE does?
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Greece
Offline Offline
Full Member
***
Karma: 2
Posts: 175
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello Dear johnwasser,

Thank you very much for the reply and sorry for the delay on my reply.

I was try to add on top the #include "Arduino.h"

But no working   smiley-sad
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 212
Posts: 8966
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you include the appropriate pins_arduino.h like from hardware/arduino/variants/standard/pins_arduino.h?
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Greece
Offline Offline
Full Member
***
Karma: 2
Posts: 175
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello Dear johnwasser,

Thank you very much for the reply.

I was try again today with you're tip, i copy the file pins_arduino.h in Core folder and i was try to compile the bellow code:

Code:
#include <Arduino.h>
//#include <pins_arduino.h>

int power;

float sensor=0;
float input=0;//voltage read on pin 2
float celsius=0;
float fahrenheit=0;
void setup(){
Serial.begin(9600);
pinMode(3,INPUT);
}

void loop(){
  power= digitalRead(3);
  if (power==HIGH){
   
  sensor = analogRead(A0);
input = (sensor*5000)/1024; // convert raw sensor value to millivolts       
celsius = input/10;         // convert millivolts to Celsius
fahrenheit = ((celsius * 1.8)+32); // convert celsius to fahrenheit
Serial.println(" sensor read");
Serial.println(sensor);
Serial.println(" --------------------------");
delay(1000);
Serial.print("Temperature: ");
Serial.print(celsius,2);
Serial.println(" degrees C");
Serial.print("Temperature: ");
Serial.print(fahrenheit,2);
Serial.println(" degrees F");
Serial.println("_ _ _ _ _ _ _ _ _ _ _ _ _ _  ");
delay (2000); // wait a second, otherwise the serial monitor box will be too difficult to read
  }
}

Without luck smiley-sad


The only good it was the errors it is only 3 from many it was before :-)


Look the error if you can please, maybe you can understend more than me. ( I am sure for this :-) )


* Error.jpg (191.53 KB, 1120x758 - viewed 12 times.)
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 212
Posts: 8966
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Looks like you have to add:
Code:
int main()
    {
    setup();
    while (1)
        {
        loop();
        }
    }

Not sure why it's complaining about pulseIn().  Looks like it might be declared twice.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Pages: [1]   Go Up
Jump to: