Go Down

Topic: Windows doesn't recognize Arduino (Read 8771 times) previous topic - next topic


I've been using Arduino UNO successfully for a while now, but about a week ago, it stopped connecting to my computer (Windows 7 Home Premium, 32 Bit).  I had successfully used it for about 6 months before this (uploading sketches, establishing a serial connection with programs on the computer, etc.).  It's not just that it doesn't work with the Arduino IDE; when I plug it in to the computer, absolutely nothing happens.  I can't see the Arduino in device manager, and the Arduino IDE doesn't see it either.  When I hit the reset button on the Arduino, the "L" button flashes which, if I am not mistaken, means that there is a boot loader on the board?  I know it's not the computer, as I was able to test it(the computer) with a friend's UNO (exactly the same board), and everything worked perfectly.  When my board stopped working, I had it hooked up to a circuit, and it was working fine (it was set up with a serial connection to Processing), and then a few minutes later, I went back to it, and it wasn't working.  If anyone has any ideas as to how (or if) I can fix it, I'd really appreciate it.


Did you test your board on your friends computer?


I haven't tried it on his computer specifically, but I have tried it on two other computers with no success.


At this point I think it may be a problem with the USB to TTL converter on the board (although I really have no idea, as I am kind of a Newbie at this  XD).  I have an external USB to TTL converter; are there any tests I could perform with this to see if this is the case?


Louis Davis

If the firmware has been corrupted on the 8U2, then you might be able to revive it by following these steps:

The 8U2 and 16U2 on the R3 UNOs is responsible for the USB to serial conversion.


Thanks for the response, I will try those instructions as soon as I get a spare minute.    I have confirmed that that is the problem, as the board worked fine this afternoon with an external USB - TTL converter.  I have an arduino R2, not an R3 - will that affect things?

Thanks so much for the advice!


Mine still does not work.  If anyone could help me please do.  I just got the arduino uno and the board does not come up in the device manager.


Mine still does not work.  If anyone could help me please do.  I just got the arduino uno and the board does not come up in the device manager.
You just bumped a 4 year old thread to ask a question about a totally different problem. Please start a new thread, and do not post in threads that have been dead for years. The forum even warns you not to with a bunch of red text :-/
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Go Up