Go Down

Topic: Uploading to Mega 2560 works in old software but not 1.0 (Read 2054 times) previous topic - next topic

Hi, I've got an Arduino Mega 2560 which works absolutely fine when I use the old alpha software (0023) but very rarely works with the latest version (1.0). When I try to upload a sketch using the new software, I almost always get a timeout message. It's not the end of the world, because I can use the old software, but I thought it was a bit odd! Has anyone else experienced anything similar?

Mubase

Is this on a mac or pc???
I have a mega2560 that uploads using a PC but not the MAC.
Dunno why.. :s
Smooberry Dooberry.

Louis Davis

After digging through the forums for awhile, it looks like the problem is caused by the new version of AVRDUDE in 1.0

The previous version of AVRDUDE was a custom Arduino version that handled the DTR toggle that is needed to reset the boards before upload.

With 1.0, the IDE now uses the regular version of AVRDUDE that handles the DTR toggle for the UNO type boards, but does not handle the toggle for the boards that use the STK500v2. The Mega2560 uses the STK500v2 protocol.

Some users have replaced AVRDUDE in the 1.0 IDE with the older version from 23 or 22 and are now able to upload successfully.

See this post:
http://arduino.cc/forum/index.php/topic,83079.msg634191.html#msg634191

Mubase

Thanks! I tried your brilliant suggestion. Renames the arduino 1.0 avr folder to avronepoint nought and copied the avr folder from 0023 to hardware/tools...
Still the same.
:(:(:(:(:(:(:(::(:(:(:(:(:(:(:(:(:(:(:s
The company I bought the board from in China is sending me a new board though so I will wait for it and see if that one works....
In the mean time I'm keeping my ears peeled. :)
Cheers 4 now,
Steve.
Smooberry Dooberry.

Louis, thank you so much! That solved the problem first time. No more frenzied jabbing at the reset button for me!

Mubase, I'm using a PC, so I guess your Mac issue is something different? Hope you get it sorted!

mellis

With the version of avrdude that comes with Arduino 1.0, can you try using the "wiring" programmer type instead of "stk500v2"?  That is, change the Mega 2560 entry in the boards.txt file.  Does that solve the problem too?

There's a Google Code issue for this, too, that would be a good place to keep track of the problem: http://code.google.com/p/arduino/issues/detail?id=806

Piton

replacing avrdude not worked for me... blink and all simple things works, but one of my big sketch doesent.



Piton

I found out that is not a problem of "size" is a problem of something inside the sketch. I tried to upload a previous version and it's uploading, then i "pumped" the size of the sketch and it's uploading fine.

At this point , what's the difference between Arduino Mega 1280 and Mega 2560? I think the sketch is calling a variable or some stuff like that,  that makes the upload stop.

Louis Davis

#10
Apr 17, 2013, 06:09 pm Last Edit: Apr 17, 2013, 11:31 pm by Louis Davis Reason: 1
Are you using any strings with "!!!" in them?

The bootloader has a special monitor mode that gets triggered by receiving three exclamation points in a row. The most common way is to create strings with !!! in them. Another way, is to have any kind of data array that has three or more 0x21 in a row.

There is a new version of the bootloader in the latest version of the IDE that does not have this monitor mode, but you would need to upload a new bootloader to your 2560 with an ISP.

Go Up