Pages: [1]   Go Down
Author Topic: arduino uno hangs host computer at startup  (Read 836 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi
i'm using an arduino uno (R3) connected through usb to a mac running 10.6.8.
whenever i start or restart the host computer with the arduino connected, the mac freezes
(after the boot sound only white screen, not even the apple appearing).
i can see the uno board getting power from the usb port and starting it's programm (simply led on pin 13 blinking).
the mac can't recover even if i unplug the usb cable. only hard reset possible.

tested on 3 different computers with two different uno boards.
duemilanove works fine, though.

this seems to be a very fundamental problem, but i can't find anything in the forums about it.

where am i going wrong here?
thanks,
p
Logged

Global Moderator
Online Online
Brattain Member
*****
Karma: 485
Posts: 18811
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Here, maybe:

https://discussions.apple.com/thread/2138237?start=0&tstart=0

I also saw a suggestion to make sure your startup disk is set to your hard disk.
Logged


Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

this seems to be a very fundamental problem, but i can't find anything in the forums about it.

I don't have an R3, but my Uno doesn't give my Mac any startup issues.
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Udine, Italy
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Same problem here. OSX 10.6 and it freezes with a UNOr3 AND a brand new arduino mega 2560.
Any hint on how to solve this?

thanx
Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Any hint on how to solve this?
Disconnect the Arduino before restarting.
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did anyone find a solution? I have the mega2560... but yup Mac startup problems... the white screen and freezing Mini Mac OSX 10.6.8 when it's connected to USB.
Did anyone find a solution. It's a problem since i have to make a remote sceduled startup and shutdown on the Mac.
Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Same problem, OSX 10.6.8 and UNO R3.
[added] It's a macbook pro, the 2010 version.

(just participating in the poll, not really a problem for me since I can follow James's "procedure")
« Last Edit: February 11, 2013, 04:14:58 pm by spatula » Logged

Global Moderator
Online Online
Brattain Member
*****
Karma: 485
Posts: 18811
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I just connected one of my Uno R3 boards to one of my Macs, running OS/X 10.7.5, after shutting it down. It rebooted OK.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm reopening this old thread to confirm the issue: Macbook Pro late 2009 with Mac OS 10.6.8 and Arduino UNO connected via USB. The Mac freezes on boot.
So, the problem seems to be related to the OS version.
Logged

Pages: [1]   Go Up
Jump to: