Go Down

Topic: Glitching TLC5940 (Read 4 times) previous topic - next topic

James C4S

You are updating the TLCs way too often.  Set your values and then update once (after the for loop sets all the values).
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Inevitableavoidance

Ah, that explained a lot, but it's still glitching for a bit now..

By the way, i connected a 7805 to power the tlc's, but the wire from the 5v-out from the arduino was still connected to the powerlane in the breadboard, and now the 7805 is powering the arduino through the 5v out pin on the arduino. Can that cause any damage or anything?

James C4S


Ah, that explained a lot, but it's still glitching for a bit now..

Can you post a hardware schematic of how you wired the TLC5940?


By the way, i connected a 7805 to power the tlc's

Not necessary, but I understand why you did.


the wire from the 5v-out from the arduino was still connected to the powerlane in the breadboard, and now the 7805 is powering the arduino through the 5v out pin on the arduino. Can that cause any damage or anything?

This is undesirable when the Arduino is being powered on its own.  With either USB or Vin/Barrel jack, there is already 5V present on the 5V pin.  You are causing two regulators (either inside your PC or the arduino regulator) to fight with the external 7805. 

7805 stuff aside, please post a schematic of how you wired the TLC5940.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Inevitableavoidance

Pretty much exactly like this: http://tlc5940arduino.googlecode.com/svn/wiki/images/breadboard-arduino-tlc5940.png
But with a 100nF capacitor between vcc and ground next to the TLC's, and 10uF at the power in on each breadboard. The TLC's are all on a separate breadboard.

James C4S

#34
Apr 02, 2012, 05:40 pm Last Edit: Apr 02, 2012, 05:42 pm by James C4S Reason: 1

Pretty much exactly like this

Any differences?

Did you follow the directions to modify tlc_config.h and make sure TLC5940.o is deleted afterwards?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up