Go Down

Topic: Cant upload to Nano (Read 430 times) previous topic - next topic

orty

Hi all,

I am brand-new to all this. I have the following error when trying to upload the Blink example to my Nano:

avrdude: stk500_getsync(): not in sync: resp=0x00

So i have vista 64-bit. the driver installed correctly as far as i am aware

i have the correct board selected (Nano w/ ATmega328) and correct port selected (COM3).

physically, the PWR led is constantly on and the L led is flashing on/off.

when i click Upload, the L led rapidly flashes 3 times and then the RX led does 3 small flashes, and then the L led goes back to the constant flashing, and then i get the above error.

i tried pressing the reset button at different points for different time intervals, but no luck.

any advice?

Nick Gammon

Did you read this?

http://www.arduino.cc/en/Guide/Troubleshooting#upload
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

orty

yes i have read that link:
- I am fairly sure ive selected the correct board and port.
- the driver installed itself (its a nano), and when i go to Device Manager under COM3, it says the latest driver is installed for that device.
- i have firewall turned off, no other active programs running.
- the nano is not connected to anything except the usb cable to pc and is sitting on my wooden desk.
- ive tried different usb cables.
- as i said above, ive tried the reset button trick, doesnt do anything.

legwinskij

Are you running Arduino 1.0 or older one ?
Verbose output could show more
on older Arduino software just hold shift while uploading
and on Arduino 1.0 go to file -> preferences -> show verbose output

Nick Gammon

I feel some sympathy because this happened to me yesterday with a Uno that had previously worked. Turned out I must have done something to the bootloader (not too surprising with what goes on here). That doesn't particularly help you, but if you have another programmer or an Arduino Uno you can set up as ArduinoISP, you might be able to work out a bit more. The verbose output might give a clue.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Runaway Pancake

When you connect/disconnect the Nano does Windows do that USB 'bing-bong' sound?
All my Nanos come in at > COM10.
Once, I bought some that came with bad cables.
"Hello, I must be going..."
"You gotta fight -- for your right -- to party!"
Don't react - Read.
"Who is like unto the beast? who is able to make war with him?"

orty

ok, so i tried connecting the nano to my laptop which is running XP and it works!! was able to successfully upload the blink example.

hmmm, maybe it is a driver issue or some other software conflict issue with my vista desktop?

well, i dont care, as long as it is working on the laptop, im happy to just work with it off that and not spend any more time troubleshooting.

thanks to all who provided their time of day to try to help me out. im sure ill be having lots of frustrating (but fun) moments which will require me to seek help here, but it seems people are genuinely helpful!

Go Up