Pages: [1]   Go Down
Author Topic: Xctu on mac  (Read 613 times)
0 Members and 1 Guest are viewing this topic.
London
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey,

So I've been searching for aaages online to try and find a way to use Xctu on my mac, without actually having to use parallels or something to run windows, so have downloaded wine instead.

There's a few tutorials on this stuff, and I've followed them completely and did all the steps as described, yet I still cannot get my com ports to talk to Xctu.  smiley-sad

I'll talk you through what I've done so far then.

Downloaded wine and xctu.
Then using terminal I created symbolic links for my 2 usb ports.

The command I used was "ln -s /dev/tty.usbmodemfa131 ~/Wine/dosdevices/com2"
So I've basically created symbolic links for my ports, and stored them in the 'dosdevices' folder within wine. All good so far, and the links show up as aliases in the dosdevices file.

So I then run xctu, and add my com ports manually. So as I've named it com2, I manually add com2.
So now when I press test/query I expect to be able to talk to com2; my Arduino connected to xbee (micro controller removed)
But no.

I have no idea where to go from here?!?! In one tutorial I found it suggests looking at the permissions on the dev ports. but 1. I'm the only user on my mac, and thus the admin, surely I have the correct permissions? and 2. I don't know how to find these permissions anyways.

The tutorial I used is http://forums.digi.com/support/forum/viewthread_thread,7076

Any suggestions and help is greatly appreciated!
Sorry if I've posted this in the wrong topic, I thought this seemed the most appropriate place!

Charlie
Logged

Pages: [1]   Go Up
Jump to: