Pages: [1]   Go Down
Author Topic: Newsoftserial site down??? arduiniana.org  (Read 771 times)
0 Members and 1 Guest are viewing this topic.
Los Angeles
Offline Offline
Full Member
***
Karma: 1
Posts: 148
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I've been trying to download the new soft serial library from arduiniana.org but the site does not respond.
Anyone know if the site is permanently down???  or does any one have the library and can share it.  I am trying to use the Xbee library but it works of off newsoftserial.... 
Logged

France
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I experienced simialar problem during the weekend.
The newSoftSerial library is now part of Arduino core (v 1.0).
You can just use the SoftwareSerial class : http://arduino.cc/en/Reference/SoftwareSerial
Logged

Los Angeles
Offline Offline
Full Member
***
Karma: 1
Posts: 148
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried it ut get errors.  It will accept the Softwareserial library when I change the #INCLUDE statement but nothing works and when I get rid of the debugging comment marks lines that start with nss.print(....) will not be recognized.

I am wondering if using a fio instead of an uno is the issue....
Is there any one on the board that might be willing to help me set up a very simple arduino xbee series 1 project???  I can pay if I can afford the price....

All I need is for an arduino fio/xbee/accelerometer to send x and y data to a an arduino uno with xbee shield.  Actually tthere are two xbee/fio/transmitting modules so there are four pieces of data that would be received by the uno...

Shoud not be that hard but I've been stumped for a while...  I thought using the library would be the solution but I cant even get the sample programs to work.

I've gotten as far as setting up the network and seeing data received at the uno end but even in api mode whee I ignore the xbee specific data, the values that should represent the accelerometer values still dont match....

What is weird is that as big as the arduino community is, not very many people like to discuss xbee.... lots of posts but few replies???
digi.com isnt much help either and the only books Ive found only deal with series 2 modules....  very frustrating....
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 212
Posts: 13531
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

find attached the 10.c version, dont think it is the latest version (but the first I could find:)


* NewSoftSerial10c.zip (8.08 KB - downloaded 3 times.)
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Los Angeles
Offline Offline
Full Member
***
Karma: 1
Posts: 148
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks!!!  I'll try it out during my lunch break and see if it does the trick!!
Logged

Los Angeles
Offline Offline
Full Member
***
Karma: 1
Posts: 148
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I just tried dropping your attached library into my libraries folder but when I tried verifying the xbee library's rx or tx examples I got the following error message.... any ideas???


In file included from Series1_Tx.cpp:21:
C:\Users\fxmech\Documents\Documents\Arduino\arduino-1.0\libraries\NewSoftSerial/NewSoftSerial.h:71: error: conflicting return type specified for 'virtual void NewSoftSerial::write(uint8_t)'
C:\Users\fxmech\Documents\Documents\Arduino\arduino-1.0\hardware\arduino\cores\arduino/Print.h:48: error:   overriding 'virtual size_t Print::write(uint8_t)'
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48556
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I just tried dropping your attached library into my libraries folder but when I tried verifying the xbee library's rx or tx examples I got the following error message.... any ideas???
Yes. First, start reading the responses from the top of the thread again. Pay particular attention to reply #1.
Logged

Los Angeles
Offline Offline
Full Member
***
Karma: 1
Posts: 148
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I read reply#1 thats what my reply#2 was based on... 
Thanks again Robtillaart for the helpful post...
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48556
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The SoftwareSerial library in 1.0 is the same as the NewSoftSerial for 0023 and earlier, except that the error you are getting was corrected.

If you can't get SoftwareSerial to work, you won't get NewSoftSerial to work, either, since it is the same code.
Logged

Pages: [1]   Go Up
Jump to: