Go Down

Topic: ArduinoISP not Working (Read 2861 times) previous topic - next topic

Whats_a_computer

Jun 27, 2012, 04:15 am Last Edit: Jun 27, 2012, 04:27 am by Whats_a_computer Reason: 1
I have an Arduino Uno R3, on a Windows XP computer running Service Pack 3, and Arduino IDE 1.0.1. The Arduino has the driver installed, and is on Com port 2. I uploaded the ArduinoISP firmware, with the heartbeat set at 20, because according to many sites, the heartbeat problem was fixed in 1.0.1(UPDATE: I have also set the heartbeat to 10, but no luck). I then proceeded to upload the blink program onto the attiny. It went twice as slow (it was running at 8mhz, instead of 16mhz), and the IDE gave the following error:

avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85



Nothing major here, a quick google search shows this is a common error, and can be ignored.

Now here is where I start having troubles. I have installed Avrdude on my computer, and want flash my chip with the Tvbgone software form Ladyada http://ladyada.net/media/tvbgone/tvbgone11.zip. I unzipped the files into my home folder: C://documents and settings/myname, and then typed the following command into the Command Prompt window in that folder: avrdude -c arduino -p t85 -P COM2 -b 9600 -U flash:w:tvbgone.hex. This is what many people have said to do, I have set the programmer to be the Arduino, I have set my chip as the Attiny85, and I have correctly named the hex file. However, I get a very common error:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Michael>avrdude -c arduino -p t85 -P COM2 -b 9600 -U flash:w:tvbgone.hex
avrdude: stk500_getsync(): not in sync: resp=0xff

avrdude done.  Thank you.


a quick google search shows that this is a common error, that can be difficult to debug, as there are so many things that can cause it. I have tried resetting my arduino right before hitting the enter key in command prompt, and several different USB ports. Can anyone suggest any ways to get around this error and flash my chip?


Osgeld

just for giggles try

-c avrisp
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Whats_a_computer


Osgeld

you probably need to prevent the reset pulse from being received by the micro, which can be easily accomplished by jamming a 1-10uf cap in the reset header, and connecting the negative side to ground.

On another note I have had nothing but headache with the Arduino as ISP sketch in 1.0, they dun fiddled with it, dont know if its fixed in 1.01
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Whats_a_computer


you probably need to prevent the reset pulse from being received by the micro, which can be easily accomplished by jamming a 1-10uf cap in the reset header, and connecting the negative side to ground.


I have a 10uF cap it there right now, do you think a lower value would work better?

Osgeld

no it would work about the same

I just noticed your using 9600, it needs to be 19200 for ISP (another thing to try)
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

Whats_a_computer


I just noticed your using 9600, it needs to be 19200 for ISP (another thing to try)


Well would you look at that. It did it! Thank you for the quick replies :)

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Michael>avrdude -c arduino -p t85 -P COM2 -b 19200 -U flash:w:tvbgone.hex

avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.03s

avrdude: Device signature = 0x1e930b
avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed
         To disable this feature, specify the -D option.
avrdude: erasing chip
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: reading input file "tvbgone.hex"
avrdude: input file tvbgone.hex auto detected as Intel Hex
avrdude: writing flash (8132 bytes):

Writing | ################################################## | 100% 13.63s

avrdude: 8132 bytes of flash written
avrdude: verifying flash memory against tvbgone.hex:
avrdude: load data flash data from input file tvbgone.hex:
avrdude: input file tvbgone.hex auto detected as Intel Hex
avrdude: input file tvbgone.hex contains 8132 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 9.67s

avrdude: verifying ...
avrdude: 8132 bytes of flash verified

avrdude: safemode: Fuses OK

avrdude done.  Thank you.




Whats_a_computer

The final command that made it work was
Code: [Select]
avrdude -c arduino -p t85 -P COM2 -b 19200 -U flash:w:tvbgone.hex. Thank you again for all the help:)

Go Up