Go Down

Topic: Can't install driver on Mac OS 10.4.5 (Read 54513 times) previous topic - next topic


Mar 24, 2006, 11:55 am Last Edit: Mar 25, 2006, 01:25 am by gck Reason: 1

Apparently, I can't get my Macs to recognize the Arduino board. I install the drivers, reboot, run macosx_setup.command, reboot again, plug in the board... and nothing happens, no entry is created in /dev. Also, the driver doesn't show up in "kextstat" or under "Extensions" in System Profiler. I've tried the driver that comes with Arduino 0003 (v2.0.1) and both 2.1.0 and 2.2.0 from the FTDI website, but no joy... I can't even see anything listed under "USB" in System Profiler when the board is connected...

The board itself seems to be fine, it works great on a Windows machine (ironically), it is recognized and I can upload sketches to it etc... The only thing that happens when I plug it into a Mac is the power LED lighting up. The USB ports on the Macs seem to be fine as well since other devices work perfectly. I have these problems on both my PowerBook and PowerMac, so I suppose I'm doing something wrong while installing the drivers. I tried to delete them completely (remove the kext, remove the receipts, clear the kext chaches) and re-install the drivers, still doesn't work...

I had it working shortly on the PowerBook after one of my desperate "delete and re-install" iterations, but after rebooting, Mac OS refused to recognize the board again... Btw, I'm using an up to date 10.4.5 (i.e. everything from Software Update installed).

Maybe someone who got it working has a hint of what could be going on? Thanks in advance...


Ok, after several hours of experimenting and researching on the internet I came up with a way on how to get the driver recognize the board. It's probably helpful for others who have problems on Tiger as well, therefore I'm sharing the procedure. All the rebooting may not be necessary, but after I got it working on the Powermac, these steps also made it work on the PowerBook... The procedure assumes that you have already installed a version of the driver but it didn't work for you...

1) Disconnect all devices that are/should be using the FTDI driver

2) Reboot

3) Delete /System/Library/Extensions/FTDIUSBSerialDriver.kext

4) Delete /System/Library/Extensions.kextcache

5) Delete /System/Library/Caches/com.apple.kernelcaches/*

6) Delete /Library/Receipts/FTDIUSBSerialDriver.pkg

7) Delete /Library/Receipts/FTDIUSBSerialDriver.kext

9) Reboot

10) Login in as an administrator user

11) Download and install the latest Mac OS X driver from the FTDI: it's 2.2.0 at the time of writing. Don't be confused because it says "Mac OS X (Intel)", it's actually universal!

12) Reboot

13) Log in as an administrator user. Run the macosx_setup.command

14) If you usually work as a non-admin user, log out and log in as that non-administrator user.

15) Open a terminal and su to your adminstrator user.

16) Run macosx_setup.command again in the su'd shell (this will set the appropriate permissions for your non-adminstrator user. The script is clever enough to infer the correct user name even though you are in a su shell).

17) Reboot and log in. Attach the Arduino board to the USB cable, then plug the other end into the Mac. The kext should load and the appropriate entries in /dev should be created.

18) Start the Arduino IDE and select the correct port. Set the baud rate to 19200. It is best to always use the same physical USB port to connect the board since otherwise, the driver will assign a different serial port to it and you have to select the correct port under "Tools" all the time...

3 more things: Do not connect the board before installing the driver. Do not keep the board attached when you shutdown, reboot or power up. Do not touch the metal casing of the USB port on the board while it is connected/being attached. I believe the combination of those 3 things caused the problems I had...

I hope this saves somebody some time and nerves...


Mar 25, 2006, 04:51 pm Last Edit: Mar 25, 2006, 04:51 pm by mellis Reason: 1
Glad you figured it out.  Thanks for the great instructions; I added this to the FAQ.


Apr 01, 2006, 01:46 pm Last Edit: Apr 01, 2006, 01:49 pm by will_schrimshaw Reason: 1
hi there,
i am having a similar problem on my powerbook. the problem is, I am running 10.3.9 so can't use the intel friendly drivers. any ideas?
i've tried the drivers from the download site and those that come with the ide download (both version 2.0.1). i get the following message when I connect my board:

The system extension "/System/Library/Extensions/FTDIUSBSerialDriver.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.



The latest PPC only drivers from FTDI's website are mislabeled, when you download them, you actually get v2.1.0, not 2.0.1 as advertised. The "real" 2.0.1 comes with Arduino 0003, but I suggest you download from the FTDI site since 2.1.0 says something about fixing rx/tx errors (which sounds important).

Anyways, have a look here: http://www.makingthings.com/products/FAQ/faq_troubleshoot.htm, especially at the part where it says "enfoce the proper ownership and permissions on the driver files". The error message you get indicates that the driver is properly registered with OS X and it actually tries loading them, maybe it's really just the permissions.


thanks for the link, very useful.
all i had to do was sort out the permissions, ownerships and so on.



Feb 06, 2007, 03:56 am Last Edit: Feb 06, 2007, 05:43 am by neosurreal Reason: 1
sorry. such a beginner here. i'm having the problem listed above. i tried to follow the instructions but no success. a true novice question: how do you run the macosx_setup.command? i'm using os 10.3.9.

and also the link provided about ownership/persmissions doesn't exist anymore.  



sorry. such a beginner here. i'm having the problem listed above. i tried to follow the instructions but no success. a true novice question: how do you run the macosx_setup.command? i'm using os 10.3.9.

and also the link provided about ownership/persmissions doesn't exist anymore.  




Hi everybody. I had the same problem as gck. I followed his tutorial but it didn't worked: the mac still couldn't see the Arduino.
I thought that I had already installed a USB-Serial driver for a PIC board. After desinstalled it, and followed gck's tutorial again, it now works!

The driver I had to remove was for the PL2303: http://sourceforge.net/projects/osx-pl2303/
Here are the instructions about how to do it:
PackageMaker does not support uninstall! Removing the driver can be done by executing the following steps:
-open a terminal
-type: kextunload /System/Library/Extensions/osx-pl2303.kext/
-The command prompt ask for you administrator password
-type: sudo rm -r /System/Library/Extensions/osx-pl2303.kext/
-The command prompt ask for you administrator password
-type: sudo rm -r /Library/Receipts/osx-pl2303.pkg/

The driver should be uninstalled.

I am now ready for Arduino world. Thanks again to gck !


I have discovered that the FTDI-drivers will be incorrectly installed if you have a case-sensitive file system (like HFS+ with case-sensitive turned on). This applies to at least 2.2.6 and 2.2.7.

Note: This fix ONLY for systems with a case-sensitive filesystem (if you don't know wheter this fix applies to your system, it most likely doesn't).
1. The fix is to move the entire kext folder "FTDIUSBSerialDriver.kext/" from "/system/library/extensions" to "/System/Library/Extension" (note the difference in case).
2. Reboot
3. Things just workTM




Dec 10, 2008, 12:32 pm Last Edit: Dec 10, 2008, 01:42 pm by DaveF Reason: 1
Hi, I'm having similar problems, but I'm on OSX 10.5.5.

Loads of those folders and files don't exist in the same places anymore!

/System/Library/Extensions/FTDIUSBSerialDriver.kext is in the same place, most of the rest are in folders that don't even exist. Anybody got an idea of how to do this on the new OSX?



CORRECTION: oops, my bad. Although the receipts folder DOESN'T show up in finder, it is visible from the terminal. I had no idea that even happened....rookie! Thanks....


The Serial Port is grayed out under the Tools menu in my system (iBook G4 running OS 10.4.11).  I tried to follow the process that was in the Arduino 13 folder, but got stuck at step 16 where I could not figure out how to run the macosx_setup.command.  I then noticed that there was an updated version of Arduino and downloaded Arduino 15, but in that folder there is no mention of a any process to fix my problem.  So, I figured that maybe the problem would go away; however, I have the same problem with Arduino 15.  I am just dying to get to use my "compleanno" present, but having no luck.  By the way, I downloaded the latest version of the FTDI driver, which is FTDIUSBserialdriver v2.2.10.


im having trouble with Mac OS 10.5.7
i've been using the arduino on my mac for a couple of months now, but today the arduino suddenly didn't show up in the Tools menu..

the weird thing is that at first the arduino did show in the arduino Tools menu. then i openend maxmsp to send the arduino's data there, but the arduino wasn't listed in the serial ports for maxmsp.
after rebooting the arduino also didn't show up in the arduino Tools menu..

i've tried gck's method above but it didn't solve the problem
any suggestions would be welcome



I am still having trouble uninstalling the new FTDI USB Serial Driver from my Mac.
it is version 10_4_10_5_10_6 that comes with the Arduino 18 download.

I have done all the steps in terminal, but it still won't let me install older versions of the driver cos my comp supposedly has a new version still installed......

would really appreciate any help as I have been at this for hours


Go Up