Go Down

Topic: Tools -> Serial Port greyed out on Linux (Read 88397 times) previous topic - next topic


Hi the board seems to be recognised, it shows up in /dev as ttyUSB0.  Dmesg shows:
Code: [Select]

ftdi_sio 5-2:1.0: FTDI USB Serial Device converter detected
ftdi_sio: Detected FT232RL
usb 5-2: FTDI USB Serial Device converter now attached to ttyUSB0
usb 5-2: New USB device found, idVendor=0403, idProduct=6001
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-2: Product: FT232R USB UART
usb 5-2: Manufacturer: FTDI
usb 5-2: SerialNumber: A40018qs

The problem is the tools-> serial port oprion in the menu is greyed out and when i try to upload to the arduino i get the ERROR:

Code: [Select]

processing.app.SerialException: Serial port 'COM1' not found.  Did you select the right one from the Tools > Serial Port menu?

I have changed the serial port option in the arduino/lib/preferences.txt file to /dev/ttyUSB0 but i still get the COM1 error suggesting the preferences isnt being recognised.

any ideas??

thanks x


not familiar with linux, but perhaps reinstalling the usb drivers or finding updated usb drivers and installing those?



you need to make sure you actually have read/write permissions on /dev/ttyUSB0
if you have an up to date linux system device files are created on the fly by UDEV, so using chmod will only work until you re-plug the board.

on openSUSE users must be members of the UUCP group to get proper access rights to serial ports.

Code: [Select]
crw-rw---- 1 root uucp 4, 64 2009-04-14 12:16 /dev/ttyS0


On Ubuntu 9.04 i386 desktop, it worked after I added my account to the "dailout" group (which requires re-login to enable):

Code: [Select]
$ ls -l /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 0 2009-07-04 15:23 /dev/ttyUSB0
$ sudo usermod -aG dialout <mylogin>


I had the same problem on Fedora 11.  I had extracted the software in my Downloads directory.  I re-extracted in /usr/local/ and  the com port option in Tools is no longer greyed out.  After selecting /dev/ttyUSB0 it uploads to my Duemilanove which is now merrily blinkin' it's little backside off.


as root try
[edit]echo "ciao" > /dev/ttyUSB0[/edit]

do you see the rx pin on arduino blinking?


This is an update and partial retraction of my entry of 10-09-2009: Tools>Serial Port is still greyed out...unless you are executing the binary as root.  I had forgotten to exit from my "su" session (required to get arduino-0017 into /usr/local/bin).  Latest status is Tools->Serial Port (and upload capability) are currently accessible only to root in Fedora 11.  Now, if I could figure out how to extend root privileges to my user account when accessing this application...


Sorry for the up, but I bought an Arduino Duemilanove board, and I'm having the same problem.

I use openSuse 11.3, but only like a final user, so, i dont know very much about linux configurations. The only way, here,  to upload the programs to arduino board, is like root.

madworm, says that opensuse users have to be part of UUCP group to can do it without root privileges, but i went to yast2, change my user privileges from 'User, Video', first to 'User, Video, UUCP', then to 'User, Video, UUCP, TTY', but didn't work in anyways.

Can anyone help me?

ps. Sorry about the poor english, i'm still learning.


Jul 23, 2010, 08:14 pm Last Edit: Jul 23, 2010, 08:18 pm by madworm Reason: 1
Add the 'dialout' group as well, then it should work. There were some changes in 11.1 I think.

If you get errors about a "lockfile", then let us know. This can be fixed easily.



In Fedora 11 and 12, you need to add your user to the "uucp" and "lock" groups.  To do so, run the 'system-config-users' utility (or go to system->administration->users and groups), double click on your username, and check off the required groups.  Then log out and back in.

If you upgrade to Fedora 12 or higher, you'll need to add yourself to "dialout" as well.

This is all in the documentation under the F12 instructions, I don't know why they don't include the groups for F11 and older...


i simply use arduino with sudo powers  ;D
Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://t.me/genuino


(required to get arduino-0017 into /usr/local/bin)

I reckon this is the cause of many of the problems, I just install the prequisites using Synaptic (Ubuntu) and just plain old extract the Arduino program into my home folder.  The arduino program needs to write to some of its files and if its been put into the /usr/local/bin folder its going to need root privilages to run.  My arduino IDE is in /home/sv/arduino-0018, it works without a hitch, no root privileges, no messing with permissions...........


arch linux updated at last version (it's a rolling release) without sudo power = Tools -> Serial Port greyed out, arduino in the home directory... but if i upload code will try with COM1, the serial port of my pc(i think).
installed via pacman only gcc-avr, no FTDI driver
Guida per principianti http://playground.arduino.cc/Italiano/newbie
Unoffical Telegram group https://t.me/genuino



Sounds a bit 'Windows' , my PC's serial port is /dev/ttyS0 which would be called COM1 in another parallel universe :)

Go Up