Go Down

Topic: Arduino and 64Bit Ubuntu? (Read 11096 times) previous topic - next topic


Hi all,

as the title suggests, I am using 64bit Ubuntu on two of my machines, including my main PC (8.10 on one and 8.04 (RT) on the other).

Is it possible for the Arduino IDE to run on 64 bit Ubuntu?

I have a few other machines all running x86 Xubuntu, and I have a spare that I suppose I could put windows on if I had to to get an IDE that works, although I would prefer to work in Linux if this is at all possible.


Well there's linux packages so I don't see why not, the only hook might be the 64-bit but that should be ok. Only thing is you will have to uninstall bryltty (I think thats how you spell it) although the linux page on here will say redo the kernel without it which you don't need to do.

Check out the linux page on this site, I can't post links till I enough posts.


Thanks for that, I'll have a search around.


Thank you - I'll have to brush up on my German, but that looks really useful!


English install guide listing what programs you'll need to install. http://www.arduino.cc/playground/Learning/Linux


Hi, thanks very much for the link, but I think I have it!

I can't tell yet as I have installed it remotelly (SSH), and I have no x-session running so am getting a Java Swing error (Exception in thread "main" java.lang.ExceptionInInitializerError)
(Caused by: java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.)

So I think once I am at the machine it should work!

Doesn't work just get in the way sometimes? ;-)


Hmmmm....it still isn't working for some reason, I'm getting the following error:

java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver
Exception in thread "main" java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path

I have the RXTXcomm.jar file in the /jre folder and the librxtxSerial.so in the /usr/lib folder, so not sure why it can't find it.

Any ideas?


Apr 11, 2009, 02:27 pm Last Edit: Apr 11, 2009, 02:27 pm by vbu Reason: 1
In my install, librxtxSerial.so is in my /arduinofolder/lib folder.
Maybe you could try putting a symlink in there to your  /usr/lib/librxtxSerial.so ?




Hi, thanks for that - I'll give that a try in a little while.

In the meantime I cheated and blew the dust off of my old XP laptop! ;-)


Hhhmmm...tried putting a symlink in my ~/arduino/lib folder but I still get the same error.

I'm completely lost now :-(  

Whilst I can use Windows, I'd rather use an OS that won't die on me at crucial moments as it did last night  :-/


Just had a closer look at my install.

In /usr/lib/jvm/java-6-sun-

I have the following:

Code: [Select]

-rwxr-xr-x 1 root  76K 2009-02-20 01:35 librxtxI2C-2.1-7.so
-rwxr-xr-x 1 root  851 2009-02-20 01:35 librxtxI2C.la
lrwxrwxrwx 1 root   19 2009-02-20 01:35 librxtxI2C.so -> librxtxI2C-2.1-7.so
-rwxr-xr-x 1 root  56K 2009-02-20 01:35 librxtxParallel-2.1-7.so
-rwxr-xr-x 1 root  881 2009-02-20 01:35 librxtxParallel.la
lrwxrwxrwx 1 root   24 2009-02-20 01:35 librxtxParallel.so -> librxtxParallel-2.1-7.so
-rwxr-xr-x 1 root  77K 2009-02-20 01:35 librxtxRaw-2.1-7.so
-rwxr-xr-x 1 root  851 2009-02-20 01:35 librxtxRaw.la
lrwxrwxrwx 1 root   19 2009-02-20 01:35 librxtxRaw.so -> librxtxRaw-2.1-7.so
-rwxr-xr-x 1 root  76K 2009-02-20 01:35 librxtxRS485-2.1-7.so
-rwxr-xr-x 1 root  863 2009-02-20 01:35 librxtxRS485.la
lrwxrwxrwx 1 root   21 2009-02-20 01:35 librxtxRS485.so -> librxtxRS485-2.1-7.so
-rwxr-xr-x 1 root 184K 2009-02-20 01:35 librxtxSerial-2.1-7.so
-rwxr-xr-x 1 root  869 2009-02-20 01:35 librxtxSerial.la
lrwxrwxrwx 1 root   22 2009-02-20 01:35 librxtxSerial.so -> librxtxSerial-2.1-7.so

Do you have any librxtx files in your java jre folder ?



I had the same problem. Mine was solved by the hint from Veronica (thanks!).

What I did was (from the arduino install path):

Code: [Select]
sudo apt-get install librxtx-java
ln -sf /usr/lib/librxtxSerial.so lib/librxtxSerial.so

I'm on Ubuntu 9.04 x64 using arduino 0015.


Jul 08, 2009, 01:52 am Last Edit: Jul 08, 2009, 02:04 am by rp3 Reason: 1
I wonder if I can get some help as well, as I have a similar error.  When I hit the "monitor serial port" button the IDE crashes and I get a error log from java.

I installed the file mentioned and did the link to no avail...




GOT IT TO WORK WITH THIS http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1233939776/15

UPdated Serial thingy and now it works kewl, now to play with my new Accelometer!

Go Up