Go Down

Topic: IDE fail "...rename 'core\core.a'; reason: File exists" or "reference to main" (Read 385 times) previous topic - next topic


Hello and thank you for helping.

I have been using Arduinos for years.  Currently using 32U4 as "Leonardo".  Windows 10.  IDE 1.8.5.  Uninstalled, erased directory and re-installed.  I have erased all libraries in the Arduino directory.

My problem manifests in two ways:

1) attempting to VERIFY a known good sketch, I get the following error message  (32U4 board is not plugged in to USB port or is plugged into USB port - no difference):

c:\programfiles(x86)\arduino\hardware\tools\avr\bin\../lib/gcc/avr/4.9.2/../../../../avr/bin/ar.exe: unable to rename 'core\core.a'; reason: File exists

I can sometimes work around this bug by verifying a NEW sketch with empty setup() and loop() statements, but this has started to fail resulting in an error statement ending in something about unresolved reference to main.

Under this condition, if I switch to UNO, it usually verifies, but switching back to Leonardo it does not verify.  Killing / reopening the IDE several times (over 10) does not affect the outcome. 

I am running McAfee and have tried turning it off, with uncertain results.  The intermittent nature of the bug does not allow for certainty.  The IDE will be working fine for awhile, then start exhibiting this behavior.  Many times, verifying an emptly sketch will allow me to continue working, sometimes it leaves me at wits end.  I know this or a similar bug has been reported years ago, but I could not find a resolution.

Any ideas?  Thanks again.


Same here : unable to rename 'core\core.a'; reason: File exists
tried running as Admin
changing folder permissions
changing install location of ide....


I have the same problem. Sometimes it says Unable to rename arduino.ar reason: File exists. I've tried reinstalling the IDE and libraries from scratch, but no luck.

Has anyone found an answer?

Go Up