Go Down

Topic: MKR 1400 (Read 2710 times) previous topic - next topic

mariusdima

Hi,

don't know if anyone tried so far but I'm the process to make a modem test after I tried the other examples  form MKR GSM library  https://www.arduino.cc/en/Reference/MKRGSM

First I thought that APN is not correct in order to make a simple data connection then send an SMS,

In the end I removed my SIM from the board and test is stuck at 'Starting modem test...'

Did anyone tried this before?

/W10 Enterprise . Arduino IDE 1.8.2

sandeepmistry

Hi @mariusdima,

I just tried the TestModem example with both a SIM and without a SIM, all looks good.

Could you please add the following to the sketch in setup():

Code: [Select]

  // initialize serial communications and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for Leonardo only
  }

  MODEM.debug(); /// <---- Line to add



Then provide us with the output. Also, do you have a battery connected to the board?

Which sketches were you using previously, do they still work?

mariusdima

Hi @sandeepmistry,

had a bit of more research on this .. tried mainly default samples provided by the library.

Got one battery at 1100 mAh but it looks like this should be at min 1500 mAh in order to work, ordered one from Amazon

Can you confirm?  :o

Thanks!



innometrix

Hi
I have a 1000 mAh and a 2000 mAh Lipo Battery and the testmodem example works perfectly, I get the IMEI number of my modem.
But I have a problem with GsmWebClient and TestGPRS.
The system hangs systematically on gsmAccess.begin(PINNUMBER).
My SIM card does not have a PIN, so I used #define SECRET_PINNUMBER     "".
I also tried gsmAccess.begin(NULL).
In debug mode : GSM gsmAccess(true) using GsmWebClient example
I read this :
AT
OK
AT+IPR=921600
OK
AT+UPSV=3
OK
AT+CPIN?
ERROR
AT+CPIN?
ERROR
AT+CPIN?
ERROR...........


My SIM card works very well in a SIM900 !!!

sandeepmistry

Hi @mariusdima,

Yes, 1500 mAh is the minimum recommended size, as stated on the product page: https://store.arduino.cc/mkr-gsm-1400

mariusdima

Ok.. got 2 mkr1400 now and tried with 2 different SIM cellular data enabled and no data connection what so ever. 

On one mkr1400 got working the modem test without the SIM .. but no further more.

Tried almost all examples from MKRGSM library, no luck so far (:


Hi @mariusdima,

Yes, 1500 mAh is the minimum recommended size, as stated on the product page: https://store.arduino.cc/mkr-gsm-1400

sandeepmistry

Hi @mariusdima

Do the scan networks, voice and SMS sketches fail as well?

Could you add this to the top of the sketches you are trying and provide the output from the serial monitor?

Code: [Select]

MODEM.debug(); /// <---- Line to add

mariusdima

Thanks for this @sandeepmistry  that is something else ... enabled debugging

  • first mkr 1400 is not responding - attch pic
  • second mkr 1400 doing a gprs test

sandeepmistry

#8
Dec 15, 2017, 03:26 pm Last Edit: Dec 15, 2017, 03:54 pm by sandeepmistry
Hi @mariusdima,

For the MKR GSM 1400 that is not responding, it might have a defective SIM slot. Could you please try the stock GsmScanNetworks.ino sketch and add a "MODEM.debug();" line at the start of "setup()". Then provide us with the output again.

The debug output from the GPRSTest sketch looks fine, I see a "TEST COMPLETE!" line which means it was successful.

nikaiverioni

Just got my MKR 1400 board (I am a newbie. Never done any arduino projects before and don't know how to code).
Can somebody help me with a simple code?

All I want for now is to receive SMS to my MKR 1400 and flash a light connected to my digital pin. That's all.

Please help...

Lionelo

How can i connect a speaker and micro on MKR 1400 ?

tbartels

Hello,
I can not connect to GSM with the Board.
Sim from "Things Mobile" APN: "TM" no PIN. The card words with a Board from MediaTek.
I use an antenna from Hologram Dash, which has the same u-blox chip on it.
I tried some example sketches and have inserted
MODEM.debug();
Everytime the data on serial port ends with:
+UMWI: 0,4
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK
AT+CREG?

+CREG: 0,0

OK

Then nothing more happens.
This is the result of example Sketch "GPRSUdpNtpClient"
can someone help?

Go Up