Go Down

Topic: Touch Screen Not working on 3.2" TFT LCD & Mega 2560-r3 (Read 6924 times) previous topic - next topic

ghlawrence2000

Hold off on that for now, I will DOUBLE check.......

Will be tomorrow now before I get back to you.

Regards,

Graham
UTFT_SdRaw now included in library manager!! ;) High speed image drawing from SD card to UTFT displays for Mega & DUE.
UTFT_GHL - a VASTLY upgraded version of UTFT_CTE. Coming soon to a TFT near you! 8) Shipping April 1 2016!

trojnman115

Looking at the updated version's spec sheet from IteadStudio

ftp://imall.iteadstudio.com/IM120417024_ITDB02_Arduino_MEGA_Shield/SCH_IM120417024_ITDB02ArduinoMEGAShield.pdf

I think the Touch CLK, CS and DIN are run into a 3.3V IC and the DOUT and IRQ are run to a 5V. Am I reading that right, and if so, then I should be ok removing the resistors from the DOUT and IRQ?

tconroy

Problem: When trying the calibration test in  the URTouch Calibration program I cannot get the touch screen to respond at the welcome screen (first screen).  I can run other not touch programs without any issues.

My drivers and module selections are all okay.  The (ILI6431_16, 38,39,40,41)  and (6,5,4,3,2)

"I just cannot get the screen to input the stylus".

The TFT_LCD SCREEN: http://www.elecfreaks.com/estore/3-2-tft-lcd-screen-module-tft01-3-2.html

The Shield: http://www.elecfreaks.com/estore/lcd-tft01-arduino-mega-shield-v2-0-shd10.html

Using the Arduino Mega. 

I have worked on this problem for about 72 hours, if not more.  I have tried everything. Almost.

Has anybody experienced the same issue? IF so, was there a solution.

Go Up