Go Down

Topic: Arduino Mega 2560 (Treiber) Problem! (Read 750 times) previous topic - next topic

nbartokos

Hallo Community!

Ich hab mir vor ein paar Wochen auf Amazon ein Arduino Starter-Kit von Elegoo gekauft. Ich weis, die "Arduino-Fakes" sind nicht die besten, doch bist jetzt hat alles einwandfrei funktioniert.

Ich habe heute ganz normal mit meinem Arduino gearbeitet. Als ich ihn das nächste mal an meinem Laptop anstecken wollte, ist nichts passiert. Das darauf gespielte Programm wurde ausgeführt aber mein Laptop erkennt den Arduino nicht mehr. Es kommt keine Fehlermeldung oder ähnliches sondern es passiert einfach nichts als würde ich nichts anstecken?

Ich kann versichern es liegt nicht am Kabel oder an der Stromzufuhr. Ich habe auf einen anderen Arduino (Uno) das ArduinoISP Programm geladen und dann auf das Mega-Board den "Arduino as ISP" Bootloader geladen. Nun kann ich über den Arduino-Uno als Programmer meine Programme laden, dass ist aber sehr nervig.

Hatte hier jemand mal das selbe Problem? Also wie gesagt mein Laptop erkennt ihn gar nicht mehr.. 1-2 mal gab er die Meldung, dass das Gerät nicht erkannt wurde. Soll ich mir einfach einen neuen Kaufen oder gibt es dafür eine Lösung?

MfG,
Nico Bartokos!

postmaster-ino

Hi

Unter welchem OS läuft denn Dein Laptop?
Win -> schaue im Gerätemanager, ob Du, bei angestecktem 'defektem' Arduino ein 'unbekanntes Gerät' hast.
--> Der Treiber zum USB-Wandler ist hin

Ubuntu/Mint -> stecke den Arduino ein und gebe 'dmesg' im Terminal (unter Ubuntu STRG+T, unter Mint nur übers Menü zu erreichen, STRG F1...STRG F6 öffnen eine 'andere' Konsole, dort müsste 'dmesg' auch klappen.
Zurück kommst Du von dort per SRTG F7 oder aber STRG F8 (Eine der beiden Kombinationen bringt Dich wieder auf die graphische Oberfläche, die Anderen sind reine Text-Konsolen).

MfG

Tommy56

Wenn Du ihn per Programmer / Arduino as ISP versorgt hast, ist der Bootlader weg. Da kann er nicht mehr seriell beschickt werden. Da musst Du erst einen neuen Bootlader brennen.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

nbartokos

@postmaster-ino Ich verwende Windows 10 und wie gesagt, meistens zeigt er im Geräte Manager gar nichts an als würde ich gar nichts anstecken, nur 1-2 mal hat es geklappt, dass er unter "USB-Controller" ein Unbekanntes Gerät angezeigt hat.

@Tommy56 Ist der Bootloader wirklich weg? Er kann das daraufgespielte Programm ja noch ausführen (Sorry ich bin recht neu in der Welt des Arduino's). Und wie kann ich den originalen Bootloader daraufspielen? Ich hab einen Arduino Uno mit dem ArduinoISP Programm und auf dem Mega hab ich den "Arduino as ISP" Bootloader. Ich hab versucht einen anderen Bootloader mit der Arduino IDE darauf zu laden aber ohne Erfolg

HotSystems

#4
Jan 21, 2018, 10:21 pm Last Edit: Jan 21, 2018, 10:29 pm by HotSystems
@Tommy56 Ist der Bootloader wirklich weg? Er kann das daraufgespielte Programm ja noch ausführen (Sorry ich bin recht neu in der Welt des Arduino's). Und wie kann ich den originalen Bootloader daraufspielen? Ich hab einen Arduino Uno mit dem ArduinoISP Programm und auf dem Mega hab ich den "Arduino as ISP" Bootloader. Ich hab versucht einen anderen Bootloader mit der Arduino IDE darauf zu laden aber ohne Erfolg
Du hast doch in deinem Eingangspost schon geschrieben, den Bootloader geladen zu haben. Jetzt verstehe ich die Frage nicht.
So kannst du doch auch einen Sketch aufspielen.

Edit:
Bekommst du irgendwelche Fehlermeldungen ?
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

dony

Hallo nbartokos,

Den Bootloader braucht man damit man das Arduino über die Serielle Schnittstelle programmieren kann. Alternativ kann man ein Arduino auch über den ISP flashen. Dazu braucht man aber einen ISP Programmer, das kann auch ein anderes Arduino sein.
Wenn Du den Arduino über ISP flasht, ist der Bootloader weg.
Hier ist das gut Dokumentiert: Tutorial/ArduinoISP (auch wie Du den Bootloader wieder rauf bekommst).

Oder es ist wirklich ein Treiber Problem.
Kannst Du das Arduino an einem anderen Computer testen? Ein anderes USB Kabel verwenden?
Du kannst im Geräte Manager 'hidden Devices' anzeigen lassen, da werden dann alle Virtuellen COM Ports die Du je verwendet hast angezeigt. Am besten die gesamten COM Treiber löschen aber nichts löschen wenn Du nicht weißt was Du machst!!!

lg dony
Newsticker:
Die Änderung meines Abschied Grußes ist Teil meiner Corporate Identity/Design Anpassung.

nbartokos

Hallo nbartokos,

Den Bootloader braucht man damit man das Arduino über die Serielle Schnittstelle programmieren kann. Alternativ kann man ein Arduino auch über den ISP flashen. Dazu braucht man aber einen ISP Programmer, das kann auch ein anderes Arduino sein.
Wenn Du den Arduino über ISP flasht, ist der Bootloader weg.
Hier ist das gut Dokumentiert: Tutorial/ArduinoISP (auch wie Du den Bootloader wieder rauf bekommst).

Oder es ist wirklich ein Treiber Problem.
Kannst Du das Arduino an einem anderen Computer testen? Ein anderes USB Kabel verwenden?
Du kannst im Geräte Manager 'hidden Devices' anzeigen lassen, da werden dann alle Virtuellen COM Ports die Du je verwendet hast angezeigt. Am besten die gesamten COM Treiber löschen aber nichts löschen wenn Du nicht weißt was Du machst!!!

lg dony
Ich habe andere PC's und Kabel getestet, es funktioniert trotzdem nicht es liegt am Arduino. Wie kann ich den originalen Bootloader wieder aufspielen über ISP?

HotSystems

#7
Jan 22, 2018, 11:38 am Last Edit: Jan 22, 2018, 11:51 am by HotSystems
Ich habe andere PC's und Kabel getestet, es funktioniert trotzdem nicht es liegt am Arduino. Wie kann ich den originalen Bootloader wieder aufspielen über ISP?
Ja, das geht über ISP, so wie du es oben schon geschrieben hast.


Und was ist mit Fehlermeldungen ?
Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

michael_x

Dony's Beitrag war evtl. etwas zu umfangreich :)

...
Wenn Du den Arduino über ISP flasht, ist der Bootloader weg.

Hier ist das gut Dokumentiert: Tutorial/ArduinoISP (auch wie Du den Bootloader wieder rauf bekommst).
...
lg dony
Werkzeuge--Bootloader brennen (braucht einen Programmer, also deinen Uno mit ISP-Sketch)
ist dir evtl. ausser Sicht geraten...

dony

#9
Jan 22, 2018, 12:08 pm Last Edit: Jan 22, 2018, 12:51 pm by dony
Wie kann ich den originalen Bootloader wieder aufspielen über ISP?
Quote
Ich habe heute ganz normal mit meinem Arduino gearbeitet. Als ich ihn das nächste mal an meinem Laptop anstecken wollte, ist nichts passiert. Das darauf gespielte Programm wurde ausgeführt aber mein Laptop erkennt den Arduino nicht mehr. Es kommt keine Fehlermeldung oder ähnliches sondern es passiert einfach nichts als würde ich nichts anstecken?
Hallo,
Ich werde Dir helfen so gut ich kann aber zuerst will ich sichergehen das es daran liegt.

Du hast einen UNO der nicht funktioniert?
Leuchtet die Power LED?

Du schreibst hier:
Quote
Ich habe auf einen anderen Arduino (Uno) das ArduinoISP Programm geladen und dann auf das Mega-Board den "Arduino as ISP" Bootloader geladen. Nun kann ich über den Arduino-Uno als Programmer meine Programme laden, dass ist aber sehr nervig.
Wenn ich Dich richtig verstanden hab, funktioniert das uploaden via ISP? Das ist dann schon der halbe Weg.

lg dony
Nachtrag: Ich frage so blöd, weil ich nicht weiß was Du vor Dir liegen hast.
Um ein Uno via Mega über ISP zu programmieren muss eine bestimmte Verkabelung her, ein bestimmtes Sketch auf das ISP Arduino und auch Einstellungen in der IDE. Da Du schreibst, dass Du das bereits erfolgreich gemacht hast, gehe ich davon aus das Du weißt wovon ich spreche, falls das nicht so ist dann frag einfach. ;)
Newsticker:
Die Änderung meines Abschied Grußes ist Teil meiner Corporate Identity/Design Anpassung.

HotSystems

Um ein Uno via Mega über ISP zu programmieren.....

Du schreibst immer sehr ausführlich, das ist den Usern sicher auch sehr hilfreich.

Allerdings solltest du auch ausführlich lesen, denn im Post #1 steht, der TO hat den Bootloader eines Mega über ISP mit einem Uno geflasht.
Und er möchte es wieder machen, warum weiß ich allerdings noch nicht.
Es hat ja schon funktioniert.

@nbartokos
da du per ISP flashen kannst und vermutlich auch den Bootloader, liegt das Problem evtl. am USB-Serial-Wandler auf dem Mega.
Daher solltest du unbedingt die Fehlermeldungen posten.

Oder siehst du keine, dann schreibe das bitte.

Anders kommen wir nicht weiter.


Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

dony

Allerdings solltest du auch ausführlich lesen
Hallo,
Damit hast Du bestimmt Recht, allerdings muss ich Anmerken das der erste Satz des TOs mich offensichtlich sehr verwirrt hat.

Quote
Ich hab mir vor ein paar Wochen auf Amazon ein Arduino Starter-Kit von Elegoo gekauft.
Hab das gegoogelt und einen Uno Klon gesehen. :smiley-confuse: Viele Anbieter, noch mehr Starter Sets und noch mehr Klone.

Danke für die Auflösung!

Wenn es am USB-Seriell-Wandler liegt, kannst Du theoretisch den Uno dafür verwenden. Allerdings weiß ich nicht ob das herausnehmen des Mikrokontroller am Uno reicht um auf den Mega zu schreiben. (Firmware am 16u2)

lg dony
Newsticker:
Die Änderung meines Abschied Grußes ist Teil meiner Corporate Identity/Design Anpassung.

nbartokos

Du schreibst immer sehr ausführlich, das ist den Usern sicher auch sehr hilfreich.

Allerdings solltest du auch ausführlich lesen, denn im Post #1 steht, der TO hat den Bootloader eines Mega über ISP mit einem Uno geflasht.
Und er möchte es wieder machen, warum weiß ich allerdings noch nicht.
Es hat ja schon funktioniert.

@nbartokos
da du per ISP flashen kannst und vermutlich auch den Bootloader, liegt das Problem evtl. am USB-Serial-Wandler auf dem Mega.
Daher solltest du unbedingt die Fehlermeldungen posten.

Oder siehst du keine, dann schreibe das bitte.

Anders kommen wir nicht weiter.



Der UNO funktioniert einwandfrei. Der Mega2560 ist das Problem. Über ISP kann ich erfolgreich meine Programme laden, aber nicht mehr über USB. Es gibt auch keine Fehlermeldung, denn wenn ich den Mega mit dem PC verbinde, passiert einfach nichts. Ich denke es liegt einfach an den USB-Seriel-Converter.

Mir wurde gesagt, dass die USB-Verbindung nicht mehr funktioniert wegen dem "Arduino as ISP" Bootloader und ich wollte wissen wie ich den Original-Bootloader des Mega's wieder aufspielen kann, denn über ISP kann ich nur diesen einen aufspielen, bei den anderen kommt nur die Meldung "Brennen des Bootloaders fehlgeschlagen"

HotSystems

Ich glaube nicht, dass es keine Fehlermeldung gibt, wenn es nicht funktioniert.
Dann stelle mal in den Einstellungen "Ausführliche Meldungen" ein.

Wenn das flashen des Bootloaders ohne Fehlermeldung durchläuft, dann ist dieser auch drauf und du kannst ihn benutzen.
Und es ist ein "Originaler Bootloader".

Und bei welchem anderen kommt eine Fehlermeldung ?

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

dony

#14
Jan 23, 2018, 08:54 am Last Edit: Jan 23, 2018, 09:09 am by dony
Hab das auf youtube gefunden: Bootloader Uno, Nano, Mega.

lg dony
Newsticker:
Die Änderung meines Abschied Grußes ist Teil meiner Corporate Identity/Design Anpassung.

Go Up