Go Down

Topic: Can't retrieve exact Serial1 from Yun (gibberish) when it works on Leonardo (Read 125 times) previous topic - next topic

danass

Hello,
I'm connecting a GSM/SIM CARD (A6 Ai Thinker) to an Arduino Leonardo.
I'm using Serial to send commands and print the results. I use Serial1 to communicate with the A6 controller.

I get good results with Leonardo, using Serial1 and connecting it to RX and TX.

Although SoftwareSerial can work (I connect it to port 10, 11) it is much slower on Leonardo and gives errors.

I tried to connect a wifi chip (esp8266), but it couldnt make it work on Leonardo.

I'm now trying on Arduino Yun to run my A6 and use builtin wifi.

Im using the same settings, Serial and Serial1.
Though my controller is working (i can send sms over network), i cannot read the Serial1: i get only ⸮
⸮⸮⸮⸮⸮ and other gibberish.

I tried different speeds, but my A6 works only at 115200.
I tried different modes. Some of them work like SERIAL_7O2 (not sure exactly 702 or 701 or another), but still give me gibberish. SotwareSerial works better, but i have many missing letters and errors.

Does anyone has an idea why Leonardo would be right, when Yun wouldn t?

Thank you
 



ballscrewbob

The YUN uses a different processor than the Leonardo.
Make sure that any libraries you want to use are suitable for each board.
This is not always the case so you might have to use a different lib to get the same results.

Serial gibberish is usually a sign of a mismatch in communication protocols so you may also want do double check those.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

oqibidipo

On the Yún Serial1 is used to communicate with the Linux processor, so you cannot use it to connect to the GSM card.

danass

Well, maybe it doesnt communicate.. but it still send receive the command as my GSM is working! It just doesnt print well what is happening.
What is the simple way to communicate with the GPS from linux and run the arduino loop?

thx

ieee488

Well, maybe it doesnt communicate.. but it still send receive the command as my GSM is working! It just doesnt print well what is happening.
What is the simple way to communicate with the GPS from linux and run the arduino loop?

thx
Perhaps actually reading the documentation would help.

https://www.arduino.cc/en/Guide/ArduinoYun

Go Up