Go Down

Topic: Adding DUE board files to IDE manually (Read 4728 times) previous topic - next topic

zootalaws

#15
Jan 04, 2018, 07:08 am Last Edit: Jan 04, 2018, 08:34 am by zootalaws
I am on my home network, don't have a proxy and my firewall is minimal - all geared towards preventing incoming, not pulling from inside the network.

But when I load the 1.8.5 IDE on Mac OS High Sierra, the only options in Board Manager is AVR - there are no options to upload any other board.

I would like to use my new Due :(

This is a fresh install of 1.8.5. I deleted the Arduino15 folder, cleared out everything and started from scratch, but can't add anything.

If I add specific files for board in Preferences - for example ESP8266 and Linkit One - it works fine - just no definitions for Arduino SAM.

I don't know what else to try.



pert

@zootalaws, please do this:
  • Close the Arduino IDE if it's running (this is to clear any output that might have been on the console window from your previous work).
  • Start the Arduino IDE.
  • Tools > Board > Boards Manager
  • Wait for downloads to finish
  • Click "Close"
  • If there is any text in the black console window at the bottom of the Arduino IDE window please copy all of it (you might need to scroll up to get it all), then paste it here using code tags (</> button on the toolbar).

zootalaws

@pert -- AHA!

Good tip.


Code: [Select]
http://downloads.arduino.cc/packages/package_index.json file signature verification failed. File ignored.

I searched on this error and saw your other posts - I subsequently deleted the Arduino15 folder, restarted, checked the proxy settings (none - I don't have one, auto - makes no difference).

Deleted Arduino, deleted Arduino15, reinstalled, reloaded, same message every time even on a vanilla system.

I can open the http://downloads.arduino.cc/packages/package_index.json page and even parse the json through one of my json apps and all is well, but errors every time when it comes to verifying the signature.

I tried your other check of involving the library manager and it updated fine - no error message.

How is the json signature verified? Can I manually add the json file?

zootalaws

Anything?

I've tried over many days, rebooted the router, connected via ethernet rather than WiFi and still the same error message about 'signature file verification failed'

Am I losing my mind? :)

pert

Another cause might be your antivirus software. Try TEMPORARILY disabling your antivirus just long enough to run Boards Manager and check whether the problem goes away. If so, you will need to modify your antivirus settings to whitelist the file, process, or folder that's being blocked.

PhysUdo

I know this topic was dead for a long time now but I have the same problem and I cannot resolve it. I have a company network, therefore I cannot install the boards easily via the arduino IDE. This is a hard requirement and I have no possibility to fix this! Therefore I have to manually install the board (I am using an Arduino MKR 1400 GSM). I downloaded the ArduinoCore-samd-master from GitHub (https://github.com/arduino/ArduinoCore-samd) and after installing this manually into ArduinoRoot/hardware/arduino/sam and executing the post_install.bat I saw my arduino in the IDE.

Nevertheless, when compiling, I get the error "exec: "/bin/arm-none-eabi-g++": file does not exist". I tried installing the gcc-arm-none-eabi and also placing the download of the arm-none-eabi-gcc directly into the arduino directory but nothing changed my error... can you help me?

pert

after installing this manually into ArduinoRoot/hardware/arduino/sam and executing the post_install.bat I saw my arduino in the IDE.
From the path, it seems you're not at all following my instructions. Are you installing it into the Arduino IDE's installation folder? It's possible that could be easier (I've never tried it), but it has the disadvantage that you will need to redo the installation every time you update to a new version of the Arduino IDE.

The architecture folder must be named samd, not sam.

Go Up