Go Down

Topic: [Solved] Stuck: Connecting to mqtt broker... (Read 2979 times) previous topic - next topic

sgerved

Aug 20, 2017, 01:55 pm Last Edit: Sep 11, 2017, 04:10 pm by 00alis
Hi,

I have a MKR1000 and is now trying to get the Arduino Cloud to work. I have made a new property and so on. I can connect to the wifi and is entering the loop function.
But when i reach the MKR1000.poll() function it is stopping at Connecting to mqtt broker...
So is the cloud down? And is there a status page for the mqtt broker?

Kind regards
Steffen
MKR1000 and Uno

sgerved

After a little research, it seams that the ssl certificate for https://mqtt.arduino.cc:8883 is expired, host and port from the source code.
So does this mean that the Arduino Cloud is no longer supported or ?
MKR1000 and Uno

ballscrewbob

Down here too.

It is still quite experimental (and temperamental too LOL).

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

sgerved

Hehe, experimental it is :) And the certificate expired 240 days ago.
Well, the idea for Arduino Cloud is good, :)
Is there an alternative like it?
MKR1000 and Uno

sandeepmistry

Hi Everyone,

We've resolved the issues with the certificates. Please let us know if you still encounter any problems. Thanks.

sgerved

I'm still stuck at the Connecting to mqtt broker...
MKR1000 and Uno

ballscrewbob

Yes there is still an issue.

Code: [Select]

403 Forbidden

Code: AccessDenied
Message: Access Denied
RequestId: 487A40B3DB13FD15
HostId: 9FGQlzQGl0Od+Ry6Ua76KIbh/k3Ge9hWmCsE5sT63RG/4u/1MSpIWg1YcydE1vo3CRWv7BAHJ2I=


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

sandeepmistry

Hi Bob,

The cloud.arduino.cc page is working for me. Maybe it's a caching issue, what URL are you trying to access?

ballscrewbob

Hi Sandeep.

I was using the links from the CC website.
Just got back from a US trip and they are now working.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up