Go Down

Topic: PCB para acionamento de Motor com o Arduino (Read 153 times) previous topic - next topic

Vitor_Palmarin

Nov 12, 2017, 05:25 pm Last Edit: Nov 12, 2017, 05:43 pm by Vitor_Palmarin
Boa tarde,

Estou projetando uma Placa de Circuito Impresso para acionar um motor DC de 9V por meio de um relé de 5V. Estou alimentando o relé com a saída 5V do Arduino e o motor com uma bateria 9V. Coloquei um pequeno resistor entre a bateria e o motor apenas para diminuir a velocidade do motor. Após confeccionar toda a PCB, soldar os componentes e conectar ao Arduino, não obtive resultados positivos. Gostaria de saber o que estou fazendo de errado, pois não estou entendendo o motivo de não funcionar, visto que o esquemático é o mesmo que eu vi em tutorias pela internet.

Obs.: Utilizo o Arduino Uno R3.



Jeff_85

  • Você testou os componentes individualmente antes de soldá-los?
  • Você se certificou de soldar rapidamente para não danificar os componentes?
  • Esse resistor que usou é de quanto?
  • Poderia postar o código que usou para acionar?


Recomendações:
  • Avaliar se as soldas foram bem feitas. Teste a condutividade das trilhas com o multímetro.
  • Caso as soldas estejam de acordo, ou seja, componentes interligados às trilhas, você poderia aplicar um sinal de 5V no pino 1, GND no pino 3 e dar um pulso de 5V no pino 2 para ouvir o relé bater.
Se isso funcionar, é possível que haja algo errado com o código. Por isso é importante informar qual você usou!

bubulindo

O motor vai consumir bastante corrente... uma resistência em série com o motor vai ter de aguentar com essa resistência e dissipar essa potência.

Muito posivelmente a resistência vai queimar em pouco tempo a não ser que seja potente que chegue, o uqe não parece ser o caso a julgar pela placa.
This... is a hobby.

Vitor_Palmarin

  • Você testou os componentes individualmente antes de soldá-los?
  • Você se certificou de soldar rapidamente para não danificar os componentes?
  • Esse resistor que usou é de quanto?
  • Poderia postar o código que usou para acionar?


Recomendações:
  • Avaliar se as soldas foram bem feitas. Teste a condutividade das trilhas com o multímetro.
  • Caso as soldas estejam de acordo, ou seja, componentes interligados às trilhas, você poderia aplicar um sinal de 5V no pino 1, GND no pino 3 e dar um pulso de 5V no pino 2 para ouvir o relé bater.
Se isso funcionar, é possível que haja algo errado com o código. Por isso é importante informar qual você usou!
1. Componentes devidamente testados.
2. Sim.
3. Já testei de 220, 100 e 1K Ohms.
4. Para fins de teste não utilizei nenhum código, liguei direto no 5V do Arduino.

Todas as trilhas foram testadas com o multímetro.

O motor vai consumir bastante corrente... uma resistência em série com o motor vai ter de aguentar com essa resistência e dissipar essa potência.

Muito posivelmente a resistência vai queimar em pouco tempo a não ser que seja potente que chegue, o uqe não parece ser o caso a julgar pela placa.
Como a resistência que está em série com o motor é apenas para regular a velocidade, inicialmente apenas coloquei um jumper para ver se o circuito estaria funcionando.

bubulindo

Estás a usar o 2N2222?

Tens a certeza que o transistor está bom?

Ligaste o GND?

Como estás a testar se está a funcionar ou não? Medes a tensão? Estás a tentar ouvir um click? Estás a medir a continuidade no contacto do relé?

This... is a hobby.

Vitor_Palmarin

Estás a usar o 2N2222?

Tens a certeza que o transistor está bom?

Ligaste o GND?

Como estás a testar se está a funcionar ou não? Medes a tensão? Estás a tentar ouvir um click? Estás a medir a continuidade no contacto do relé?


Sim, 2N2222A, transistor em perfeito estado e GND conectado. Estou testando por meio do motor, que não é acionado e nem o relé está fazendo o click.

bubulindo

Acho que sem pegares num multimetro, não existe muito que te possamos dizer.

Pode ser mil e uma coisas... Assim de repente diria para medires as tensões quando tentas activar algo. Se não estiveres para aí virado, eu olharia a duas coisas.

1 - A bateria de 9V está boa? Essas pilhas não são ideais para aplicações com consumo de corrente.

2 - O teu relé é feito para ser usado com 9V?? Tanto quanto me lembro, os relés para tensões abaixo de 12V são relativamente raros. Talvez seja esse o problema? Se quiseres meter aqui os detalhes do relé podemos dar uma vista de olhos por ti.
This... is a hobby.

Jeff_85

Talvez pudesse postar uma ou duas fotos boas de como sua placa ficou. Principalmente da parte das soldas. Não é possível que algo tão simples esteja tão complicado para resolver.

bubulindo

Yeah, eu ia dizer que poderia ser uma solda fria também... mas como já tinha dito que as pistas estavam todas boas assumi que isso estivesse bom também.
This... is a hobby.

Go Up