Designing a new programming language for Arduino

CrossRoads:
Two symbols are two symbols, I have no problem with ==.
At the same time, context within an if( ) makes sense too, I've never written anything where I assigned a value within an if ( ) statement, that is just too convoluted for me. Write it as two lines, let the compiler deal with it.

Agreed, it is far easier to recognize what is happening with two lines, however both switch and if statements have an exception; initialization.

if( int valueNotZero = random(0,10)){
  //use valueNotZero if value not zero
}


switch( int resultOfComplexAlgo = ...){
  case whatever:
    //use resultOfComplexAlgo in case easily
  break;
}

Of course this is still subject to personal preferences, but a very tidy use none the less (keeps locals scoped to where they belong).