Arduino Forum

International => Deutsch => Topic started by: uwefed on Oct 16, 2012, 08:21 pm

Title: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Oct 16, 2012, 08:21 pm
Hallo an alle
Ab IDE 1.0 wurden einige Bibiotheken umbenannt/zusammengefaßt. Deshalb funktionieren Bibiotheken für IDE0023 und älter unter Umständen nicht mehr mit IDE1.0
Die Bibiothek WProgram.h wurde in Arduino.h umbenannt.
Um eine Bibiothek für beide IDE Versionen kompatibel zu machen, muß man in die Bibiothek statt #include"WProgram.h" folgendes schreiben:
Code: [Select]
 #if defined(ARDUINO) && ARDUINO >= 100
 #include "Arduino.h"
 #else
 #include "WProgram.h"
 #endif


Eine gute Informationsquelle sind die Release Notes: http://arduino.cc/en/Main/ReleaseNotes
viele Grüße Uwe  
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Oct 21, 2012, 09:56 pm
Using Flash Memory for string storage.
Ab Arduino IDE Version 1.0 wurde die F()-Syntax eingeführt. 
Mit ihr kann man Strings im Flash-Speicher anstatt im RAM ablegen.
Beispiel:
Code: [Select]
Serial.println(F("This string will be stored in flash memory"));

Ähnlich funktioniert auch
Code: [Select]
#include <avr/pgmspace.h>
printf_P(PSTR("This string will be stored in flash memory"));

Dazu ist aber das Include der obengenannte Bibiothek notwendig.

http://www.arduino.cc/playground/Main/Printf

Nachtrag:
Dies Fuktioniert nicht beim Arduino Due und ist nicht notwendig. Dort werden Strings per Definition im Flash abgelegt.

Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Oct 24, 2012, 04:53 pm
Neue IDE-Version

Die IDE Version 1.5 ist für den Einsatz mit dem Arduino DUE vorgesehen. Auch wenn andere Arduino Modelle in der Boardauswahl vorhanden sind, sollte diese Version nur für den Arduino Due verwendet werden.

Für alle anderen Arduino Modelle muß die IDE Version 1.0.x verwendet werden.

In einem späteren Zeitpunkt wird eine IDE-Version für alle Modelle verfügbar sein.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Dec 11, 2012, 12:47 am
Neue Arduino Plattform.

Auf arduino.cc wurde heute eine neue Arduino-Variante vorgestellt: Arduino Esplora.

Es ist eine Arduino Leonardo Variante mit vielen Sensoren on board:
einem analogen Joystick mit Zentraltaste,
4 Tastern,
einem Buzzer,
ein Mikofon PMOF-9745P-Q mit Verrstärker und Gleichrichtung,
einen LDR VT90N2,
einen Temperatursensor TMP36,
einen 3 Achsen Beschleunigungsmesser MMA7361LCR2 für +/-1,5g bzw +/-6g einstellbar über eine Lötbrücke,
ein Schiebewiderstand,
eine RGB-LED,
4 Anschlüsse für TinkerKit-Module (2 Eingänge und 2 Ausgänge)
und einen Stecker für ein TFT-Farb-Display 128x160px mit microSD Slot.
Das Display wird in Kürze presentiert werden.
Die Analogen Sensoren werden über einen 74HC4067 Multiplexer angesprochen.
Spannungsversorgung 5V über die USB-Buchse oder einen Tinkerkit Buchse.

Arduino Esplora ist einem Gamepad nachempfunden und will eine "open source game console" sein.

Die neue IDE-Version 1.0.3 beinhaltet spezifische Funktionen für den Esplora.

http://arduino.cc/en/Main/ArduinoBoardEsplora

Viele Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Jan 07, 2013, 12:21 am
Arduino auf WIN8 installieren.
Windows 8 weigert sich den Driver zu installiere da er keine digitale Signatur von Microsoft hat. Hier eine Lösung:
http://arduino.cc/forum/index.php/topic,94651.15.html

Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Mar 11, 2013, 11:59 pm
Heute wurde eine neue Version des IDE zum Download freigegeben: IDE 1.0.4.
http://arduino.cc/en/Main/Software
Neuerungen vor allem ein einziger Treiber für alle WIN-Versionen bis Win8 mit Signatur.

Quote from: http://arduino.cc/en/Main/ReleaseNotes
ARDUINO 1.0.4 - 2013.03.11

[core]
* Fixed malloc bug (Paul Stoffregen)

[libraries]
* Fixed memory leak when calling Ethernet.begin() multiple times.
* Fixed SD example listfiles.ino
* Fixed a lot of Esplora examples
* Added GSM library

[environment]
* Sort entries in preferences.txt (Shigeru Kanemoto)
* Fixed some wrong translations
* Fixed NPE due to permissions IO error
* Updated drivers for Windows (all-in-one, signature for Win8)

[bootloaders]
* Fixed a bunch of bugs on Mega2560's bootloader (Mark Sproul)
  (https://github.com/arduino/Arduino/pull/1183)


Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Apr 03, 2013, 07:29 pm
Heute wurde ein Fehler im Forum beseitigt, der Schuld daran war, daß frisch hinaugeladene Avatare nicht sichtbar ware. Funktioniert jetzt.
Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on May 18, 2013, 07:20 pm
Heute Wurde die neue IDE Version 1.0.5 freigegeben.

Änderungen: einige Fehlerbereinigungen und neue Bibliotheken für die Boards/Shields WiFi, Arduino Robot und TFT Display.
http://arduino.cc/en/Main/ReleaseNotes

Gleichzeitig erschienen Arduino Robot http://arduino.cc/en/Main/Robot auf der Basis des Arduino Leonardo
http://arduino.cc/en/Guide/Robot http://arduino.cc/en/Reference/RobotLibrary
(http://images.techhive.com/images/article/2013/05/arduino-robot-100038050-orig.jpg)

und ein Display mit SD Schacht für Arduino Explora und Robot http://arduino.cc/en/Main/GTFT
(http://arduino.cc/en/uploads/Main/GLCDFront_450.jpg)

Grüße Uwe

Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on May 02, 2014, 05:53 pm


Fehlermeldung: avrdude: stk500v2_ReceiveMessage(): timeout


Das ist ein typischer Fehler mit manchen MEGA-Boards mit fehlerhaften MEGA-Bootloadern, wenn Du drei oder mehr Ausrufungszeichen direkt hintereinander in Deinem Sketch drin hast.

Prüfe mal als erstes: Hast Du irgendwo in Deinem Sketch Text mit drei Ausrufungszeichen drin?

Wenn ja, ist Abhilfe einfach: Schlechte Grammatik mit ganz vielen Ausrufungszeichen vermeiden!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
]:D

Wenn nein, hat der Compiler drei Ausrufungszeichen bzw. die entsprechenden HEX-Codes im Code zusammencompiliert. Dann müßte man den Sketch entweder mit einem ISP-Programmer statt über Bootloader hochladen, oder sich den Sketch mal genauer ansehen, wie man die Erzeugung des problematischen Codes vermeiden kann, z.B. durch Umstellung von Variablen oder Daten oder Codezeilen.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on May 15, 2014, 10:53 pm
Heute ist ein neuer Arduino aufgetaucht: Arduino Zero.
Es liegt von der Leistung zwischen UNO und DUE. Platinengröße wie der UNO aber mit einem Atmel SAMD21 MCU, mit 32-bit ARM Cortex® M0+ core
http://blog.arduino.cc/2014/05/15/meet-arduino-zero/
http://arduino.cc/en/Main/ArduinoBoardZero
http://www.heise.de/hardware-hacks/meldung/Entwicklerboard-Arduino-Zero-Uno-war-gestern-2190980.html

Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Nov 17, 2014, 09:37 pm
Neues Design und neue Farbe soll Fälschungen erschweren.

(http://blog.arduino.cc/wp-content/uploads/2014/11/ArduinoUno-TOPsmall3.jpg) (http://blog.arduino.cc/wp-content/uploads/2014/11/ArduinoUno-BOTTOMsmall2.jpg)

Laut Blogeintrag http://blog.arduino.cc/2014/11/14/the-perfect-teal/#more-10558 wird das Design der Arduino's (neuerlich) geändert um Fälschungen zu erschweren. Arduinos mit dem neuen Disegn sollen in den nächsten Monaten ausgeliefert werden.

http://www.heise.de/hardware-hacks/meldung/Arduino-Boards-Neues-Design-soll-Faelschungen-erschweren-2458878.html

Viele Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: sschultewolter on Nov 17, 2014, 11:35 pm
Darf man fragen, in wie fern man somit Fälschungen versucht zu unterbinden?
Nur wegen der Farbe? Das wäre für die großen Unternehmen kein Problem, die Leiterbahnfarbe zu ändern. Zumal wie viele Arduinos lässt Arduino selber fertigen? Ich würde sagen, bis auf den Leonardo, Uno und Mega sind alle anderen von externen Partnern (Yun, Pro Mini, Pro Micro..)
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Chris72622 on Jan 26, 2015, 08:09 am
Hallo,

bei mir erscheint beim starten von Arduino regelmäßig folgende Fehlermeldung:

(http://fs2.directupload.net/images/150126/7tjnu5wu.png)

Dies betrifft jeden Neustart von Arduino, wenn der Rechner zuvor in den Ruhezustand versetzt wurde.

Bei erneutem Starten von Arduino funktioniert dann jedoch alles immer wie gewohnt.

Mac OS 10.10.1, Arduino 1.0.6.

Gruß Chris
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Chris72622 on Feb 03, 2015, 07:41 am
Wenn man mit Strg-T den Sketch automatisch formatiert, springt die IDE im Anschluss an irgendeine Stelle, welche man im Anschluss erneut aufsuchen muss.

Arduino 1.0.2, Mac OS 10.10.2

Gruß Chris
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: sth77 on Feb 10, 2015, 08:59 am
Es ist soweit, die Arduino-IDE hat einen weiteren Versionssprung hinter sic. Aktuell ist nun die Version 1.6.0 (stable).
Den Link zum Download findet ihr natürlich selbst hier auf der Arduino-Seite. Außerdem berichtet Golem.de über die neue IDE: http://www.golem.de/news/arduino-ide-1-6-neue-version-als-stabil-deklariert-1502-112247.html (http://www.golem.de/news/arduino-ide-1-6-neue-version-als-stabil-deklariert-1502-112247.html)
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: skorpi080 on Feb 15, 2015, 01:24 pm
Ist es normal in der IDE 1.6 dass man den Sketch erst speichern muss, bevor ein Upload erfolgen kann oder Verifizierung?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: combie on Feb 17, 2015, 10:22 am
Ja!

Beim ersten speichern muss man einen Namen vergeben.
Danach speichert es automatisch und ungefragt vor jedem Compile.


Das ist ein Feature, kein Bug.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: skorpi080 on Feb 18, 2015, 08:03 am
Ahh, so war es gedacht, ich dacht schon es wäre ein Bug.
Dann sollte es aber auch ein Menü geben es abzustellen, nervt mich nämlich.
Hab allein deswegen wieder die alte Version genommen :D
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: syslog on Feb 18, 2015, 02:00 pm
Hi,

.
Dann sollte es aber auch ein Menü geben es abzustellen, nervt mich nämlich.
einen solchen Menü/Config-Eintrag gibt es eh (in der Art von "Auto-Save when uploading" oder so, hab den genauen Wortlaut jetzt nicht im Kopf).

lg SYSLOG
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: syslog on Feb 25, 2015, 08:45 pm
Hi,

hat eigentlich außer mir noch jemand in der 1.6er IDE das Problem, dass die schliessende "Curly Brace" von einem Block (if, while, Funktion, etc.) nicht mehr korrekt "ausgerückt" wird?

Die Indentation (in der Zeile nach dem Öffnen der Curly Brace) funktioniert, aber die De-Indentation nicht.

lg SYSLOG
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: sschultewolter on Mar 12, 2015, 01:23 am
Arduino 1.6.1 erschienen. [Release Notes] (http://arduino.cc/en/Main/ReleaseNotes)

Bei der Installation kann es zu einer Warnung kommen, dass das Gerät nicht von einem zertifizierten Hersteller kommt und daher auch kein Anspruch auf Support besteht. Das betrifft derzeit die Geräte mit der USB Vendor ID von arduino.org. Auch wenn es zu dieser Warnung kommt, ist die Installation des Treibers sowie die Nutzung der IDE mit diesen Geräten möglich.(anders als es noch in Version 1.6.0 der Fall war)

Ausschlaggebener Punkt ist der Rechtsstreit zwischen Arduino LLC und Arduino S.R.L. . Unter anderem in einem Artikel auf Golem nachzulesen [hier] (http://www.golem.de/news/rosenkrieg-arduino-verklagt-arduino-1502-112371.html)

Weitere Infos im englischsprachigen Bereich des Forums:
[1]http://forum.arduino.cc/index.php?topic=307397.0 (http://forum.arduino.cc/index.php?topic=307397.0)
[2]http://forum.arduino.cc/index.php?topic=307162.msg2132678#msg2132678 (http://forum.arduino.cc/index.php?topic=307162.msg2132678#msg2132678)
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uwefed on Apr 03, 2015, 11:31 pm
In der Zwischenzeit ist auch noch die IDE 1.6.2 (am 28.3.2015) und die IDE 1.6.3 (am 02.04.2015) veröffentlicht worden.
Ob die in der Version 1.6.1 vorhandenen Warnings bei Verwendung von Arduino.org Hardware in diesen Versionen vorhanden ist, kann ich aus Mangel an Infos bzw Hardware nichts sagen.

Grüße Uwe
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: combie on Jun 20, 2015, 10:22 pm
Habe grade ein Update von 1.6.4 auf 1.6.5 gemacht.
Bin positiv überrascht!

Das unselige und unbeherrschbare scrollen, beim Textblöcke markieren ist weg.
(das hat ja voll genervt)

Auch kann man jetzt markierte Textblöcke mit der Maus verschieben.
Und bei gedrückter STRG Taste Kopieren.

Kursor in ein Wort setzen und im Kontextmenu "In der Referenz suchen" tuts jetzt auch.

Perfekt!

So langsam wird da wirklich eine funktionierende IDE draus.


Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: skorpi080 on Jun 21, 2015, 01:25 am
Nimm doch die HOURLY BUILDS, da haste diese "Bugs" etwas früher :D
Bei der 26.5.15 Version ist es schon.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Chris72622 on Sep 29, 2015, 07:35 am
Bei mir minimiert sich auch unter 1.6.5 noch immer bei jedem erneuten Öffnen das Programmfenster und wandert anschließend in die links-untere Ecke des Monitors.

Mac OS 10.10.5

Gruß Chris
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: skorpi080 on Sep 29, 2015, 11:41 pm
Mich nervt eher

Quote
Möchten Sie, dass das Programm „Arduino 2.app" eingehende Netzwerkverbindungen akzeptiert?
Dein beschriebenes Problem hab ich nicht, 1.6.6 vom 21.8.15 und auch die von heute.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Chris72622 on Nov 27, 2015, 09:00 pm
Manchmal half mir das hier:

Eingehende Netzwerkverbindungen für immer erlauben:

1. Öffne Programme > Dienstprogramme > Schlüsselbundverwaltung
2. Dann Menü Schlüsselbundverwaltung > Zertifikatsassistent > Zertifikat erstellen…
3. Dem neuen Zertifikat einen Namen geben (neuen Zertifikatsnamen genau merken!)
4. Identitätstyp: Root, selbst-signiert
5. Zertifikatstyp: Code-Signierung
6. Haken bei „Standardwerte überschreiben" setzen und auf "Fortfahren" klicken
7. Seriennummer: 1
8. Gültigkeit (in Tagen): 900 » Fortfahren
9. Emailadresse etc. beliebig einfügen » Fortfahren
10. Für die restlichen Dialoge die voreingestellten Standardwerte verwenden
Nachdem das neue, eigene Zertifikat gesichert ist, die Schlüsselbundverwaltung beenden (!!!).
11. Öffne Programme > Dienstprogramme > Terminal

Eingabe:

Beispiel für Arduino:
sudo codesign -s Arduino -f /Applications/Arduino.app

Der Pfad hinter dem -f kann durch Reinziehen des Programms ins Terminalfenster erfolgen.

Danach kurz warten und Passwortabfrage bestätigen.

Im Anschluss den Rechner neu starten.

Gruß Chris

Edit: Das Problem mit den eingehenden Netzwerkverbindungen trat meist dann auf, wenn ich per "Paketinhalt anzeigen" innerhalb des Programms (namens "Arduino"- öhöhö!) etwas verändert habe.

Dies gilt es somit also meiner Erfahrung nach zu vermeiden.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ralf9 on Jan 17, 2016, 12:37 pm
Hallo,

ich verwende unter opensuse 13.1 64 Bit die Arduino IDE 1.06 und würde gerne auf eine aktuelle Version updaten.
Hat schon jemand unter opensuse eine aktuelle Version zum laufen bekommen.

Wenn ich unter der Arduino IDE 1.6.7 versuche zu kompilieren, bekomme ich eine Fehlermeldung:

Code: [Select]
"/opt/arduino-1.6.7/hardware/tools/avr/bin/avr-gcc"  -Os -Wl,--gc-sections -mmcu=atmega328p  -o "/tmp/build99874ed3b38708d47e449b9160b5019a.tmp/Button.ino.elf" "/tmp/build99874ed3b38708d47e449b9160b5019a.tmp/sketch/Button.ino.cpp.o" "/tmp/build99874ed3b38708d47e449b9160b5019a.tmp/core/core.a" "-L/tmp/build99874ed3b38708d47e449b9160b5019a.tmp" -lm
collect2: error: ld terminated with signal 11 [Segmentation fault]


Liegt es evtl daran, daß bei der Arduino IDE 1.6.7 der eigene avr-gcc verwendet wird?

Gibt es eine Möglichkeit, daß von der Arduino IDE 1.6.7 die in opensuse installierte avr-gcc verwendet wird?
gcc version 4.8.3 (GCC)
GNU ld (GNU Binutils; openSUSE 13.1) 2.23.2

Oder kann sogar die aktuelle Toolchain_3.5.0 verwendet werden?
gcc version 4.9.2 (AVR_8_bit_GNU_Toolchain_3.5.0_1662)
GNU ld (AVR_8_bit_GNU_Toolchain_3.5.0_1662) 2.25

Gruß Ralf
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: michael_x on Jan 17, 2016, 01:20 pm
Passiert das mit jedem sketch?

"Segmentation fault" kann auch so passieren:
http://arduino.stackexchange.com/questions/13429/deprecated-conversion-from-string-constant-to-char/13443#13443
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ralf9 on Jan 17, 2016, 01:25 pm
ja, passiert mit jedem sketch. Ich habe es auch mit einigen einfachen Beispiel sketchen getestet.

Gruß Ralf
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Esron on Feb 20, 2016, 01:52 pm
Hallo zusammen,

neu hier und beim Arduino und schon ein Problem

MacBook Pro
IDE installiert
Menü wird nicht angezeigt!??

Wo liegt mein Fehler?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Mar 13, 2016, 08:55 pm
Schreibst du doch schon selbst: Mac  :smiley-mr-green:

nee, im Ernst: Poste das direkt im dt. Forum, da lesen es mehr. und mit aussagekräftigem Titel

Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Chris72622 on Mar 18, 2016, 06:56 pm
Die Arduino Software läuft wirklich gut auf dem Mac. Das kann ich zumindest für die Version 1.6.5 sagen.

Vielleicht hast Du lediglich vergessen einen Doppelklick auf das Programmsymbol zu machen.

Gruß Chris
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: stoni99 on Apr 17, 2016, 03:48 pm
Scheint ja öfters mit der neuen Version 1.6.8 Probleme zu geben?!

Hier (http://forum.arduino.cc/index.php?topic=371765.15) (#15 / #17) auch ein Fehler - scheint mit der Lib wire ein Problem zu haben...  :o

Hab wieder auf 1.6.7 umgestellt und Board's/Bibliotheken aktualisiert - seit dem Fehler weg.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: stoni99 on Aug 18, 2016, 04:28 pm
Probleme? Ja klar doch! Siehe Beitrag (http://forum.arduino.cc/index.php?topic=418230.0).  :D
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: michael_x on Aug 18, 2016, 05:18 pm
Das habe ich auch so mitgekriegt:
Nach 1.6.7 oder 1.6.9 sollte man besser auf die .11 wechseln und die .10 auslassen ;)
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Mardetuino on Dec 30, 2016, 06:25 pm
Habe jetzt die 1.8.0 installiert, und die Textzeichen sind schlechter lesbar. Das geht so in Richtung Clear-Type...
Wurde da was geändert/"verbessert"??

(http://forum.arduino.cc/index.php?action=dlattach;topic=127552.0;attach=192757) (http://forum.arduino.cc/index.php?action=dlattach;topic=127552.0;attach=192757)
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Dec 31, 2016, 09:34 am
Hab gestern auch die 1.8.0 installiert, gleiches Phänomen
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: sth77 on Dec 31, 2016, 09:48 am
Scheint ein bekanntes Problem zu sein. Die Teensyduino-Erweiterung in Version 1.34 patcht das bereits, da steht in den Release Notes: "Anti-alias font fix for Arduino 1.8.0 on Windows".
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: The_Laser_Guy on Jan 09, 2017, 11:23 am
Wenn ich das richtig sehe, wurde oben im Screenshot von Subpixel auf Graustufen Schriftkantenglättung umgestellt und das über die komplette GUI (das "Arduino auf COM11" ist in Version 1.8 ebenfalls geglättet).

Ich persönlich mag keine Form der Kantenglättung wenn es um die Schriftdarstellung geht. Leider wird in der 1.8er alles unabhängig der Systemeinstellung geglättet (ich habe kein Fontsmoothing aktiv und dennnoch ist alles verwaschen).
Hat schon jemand getestet, was der Teensyduino patch bewirkt? 
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: staivoup on Jan 10, 2017, 12:48 pm
Warum wird sowas nicht von den Systemeinstellungen übernommen?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Jan 10, 2017, 07:10 pm
Weil Java?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Mardetuino on Jan 11, 2017, 11:37 pm
1.8.1 ist auch noch geglättet. Einfach schlechter lesbar.
Wieder einmal hat es sich bewahrheitet, bei einer Arduino Version zu bleiben...

Anstatt mal nützliches einzubauen:
Boardtyp und COM Einstellung im Sketch hinterlegt. Jedes mal dieses lange auswählen nervt.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Jan 19, 2017, 08:59 pm
Probleme beim Start der IDE mit WIN10

Hallo....

seit einiger Zeit habe ich Probleme beim Start der Arduino IDE 1.6.12 unter WIN10.
Der Start der IDE dauert ca. 20 Sekunden, auch das Beenden dauert gefühlt ewig. Manchmal dauert auch das kompilieren und hochladen ewig, dann geht es wieder recht flott. Wenn es klemmt dann so dass es absolut keinen Spaß mehr macht. Oft dauert auch das öffnen und speichern eines Sketchs ungewohnt lange. Irgendwie habe ich das Gefühl dass Dateioperationen verzögert laufen.
Meinen AVIRA habe ich schon ausgeschaltet, keine Änderung. Jetzt habe ich mal die IDE 1.8.1 genommen, gleiches Verhalten. So macht das alles keinen rechten Spaß mehr.  >:(  >:(

Kennt das jemand und weiß wer was da los sein könnte?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: HotSystems on Jan 21, 2017, 05:46 pm
Kennt das jemand und weiß wer was da los sein könnte?
Das liegt sicher nicht an der IDE, sondern an deinem Windows.
Versuche doch mal über die Wiederherstellungskonsole auf ei früheres Datum zurück zu setzen.

Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Jan 22, 2017, 02:07 pm
So, jetzt habe ich ein Backup aufgespielt und geht wieder.
Aber woran das lag werde ich jetzt nie erfahren  :o
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: HotSystems on Jan 22, 2017, 02:47 pm
So, jetzt habe ich ein Backup aufgespielt und geht wieder.
Aber woran das lag werde ich jetzt nie erfahren  :o
Warum schreibst du nicht, welches Backup du aufgespielt hast ?
Windows ?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Ballon on Jan 22, 2017, 04:44 pm
Hallo
Kann mir jemand sagen was das für ein Board ist?  Habe mir ein starter kit uno Arduino bestellt aber es kamm  folgendes  Board.
Danke für eure Bemühungen!!
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: michael_x on Jan 22, 2017, 05:13 pm
Das ist kein "Arduino Uno TM", wie du schon geahnt hast.
Hat einen CH340 für die USB-Kommunikation, was inzwischen der Chinesen-Standard ist.
Wenn dein Starterkit gut ist, beschreibt es dir, wie du den reforderlichen Treiber auf deinem PC installierst.

Ansonsten hat es den atmega328 drauf, ist also uno - "kompatibel".

Dann scheinen alle Anschlüsse wahlweise als Buchsen (wie UNO, passend für Shields) und auch als Stifte zur Verfügung zu stehen. Könnte evtl. manchmal praktisch sein.

Der ISP- Anschluss scheint doppelt vorhanden: 6pol. und 10pol.
Brauchst du (hoffentlich) erstmal garnicht, wenn dann spart es dir evtl. einen 1Euro Adapter.

Wofür die zusätzlichen Taster gut sind: k.A.

Viel Spass damit!
"Ich wünsche dir eine interessante Zeit damit" (soll mal kein Fluch sein, sondern durchaus positiv) ;)

     
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Ballon on Jan 22, 2017, 05:37 pm
Das ist kein "Arduino Uno TM", wie du schon geahnt hast.
Hat einen CH340 für die USB-Kommunikation, was inzwischen der Chinesen-Standard ist.
Wenn dein Starterkit gut ist, beschreibt es dir, wie du den reforderlichen Treiber auf deinem PC installierst.

Ansonsten hat es den atmega328 drauf, ist also uno - "kompatibel".

Dann scheinen alle Anschlüsse wahlweise als Buchsen (wie UNO, passend für Shields) und auch als Stifte zur Verfügung zu stehen. Könnte evtl. manchmal praktisch sein.

Der ISP- Anschluss scheint doppelt vorhanden: 6pol. und 10pol.
Brauchst du (hoffentlich) erstmal garnicht, wenn dann spart es dir evtl. einen 1Euro Adapter.

Wofür die zusätzlichen Taster gut sind: k.A.

Viel Spass damit!
"Ich wünsche dir eine interessante Zeit damit" (soll mal kein Fluch sein, sondern durchaus positiv) ;)

     
Hei das ging aber flott Danke! Für die Info.
Das ist das erste mal das ich mich in einem Forum Melde.
Leider ist Die Gebrauchs Anweisung  Chines-isch wede mich
wohl an den Bilder Orientieren.
Nochmals Danke!!
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: HotSystems on Jan 22, 2017, 06:05 pm
Da das Board UNO-kompatibel ist, kannst du alles nutzen, was du über den UNO liest. Naja fast, da er einen anderen USB-Serial-Wandler hat.

Die zusätzlichen Taster sind nochmals als Pin rausgeführt, können somit für erste Versuche mit Tastern nützlich sein.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Jan 23, 2017, 12:05 pm
Warum schreibst du nicht, welches Backup du aufgespielt hast ?
Windows ?

Ja, ein Backup meines Betriebssystems WIN10 als es noch gut funktionierte.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: HotSystems on Jan 23, 2017, 01:16 pm
Ja, ein Backup meines Betriebssystems WIN10 als es noch gut funktionierte.
Ok, danke für die Info.
Das wird anderen mit dem selben Problem helfen.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: combie on Feb 01, 2017, 10:10 am
Das Problem "Kompilieren ist plötzlich voll lahm" konnte ich letztens bei mir selber erleben.

Das Problem trat nach einem Board Update auf.
In diesem Fall die Standard Boards, UNO usw..
(Die IDE fragt ja immer ganz lieb, ob sie das tun soll...)

Was genau schief läuft, weiß ich nicht...
Aber nach löschen des Boards Gedöns in %Appdata%...Arduino15
Lief alles wieder in gewohnter Geschwindigkeit.

Seit ich auf "portable" umgestellt habe, tritt das Problem nicht mehr auf.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: RIN67630 on Jun 03, 2018, 09:25 am
Boardtyp und COM Einstellung im Sketch hinterlegt. Jedes mal dieses lange auswählen nervt.
Klingt erstmal nicht schlecht... Wenn das programmtechnisch machbar wäre...
Aber ob man sich auf die COM Einstellungen verlassen kann?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Jun 03, 2018, 11:05 am
Aber ob man sich auf die COM Einstellungen verlassen kann?
Bei Windows besser nicht
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: postmaster-ino on Jun 03, 2018, 12:19 pm
... und unter Linux heißt das Teil anders ;)
Denke, der MAC wird hier auch mit anderen Begrifflichkeiten aufwarten können.

Trotzdem ist dem Mac- wie Linux-Nutzer bewusst, was eine COM ist(war).

MfG
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: mde110 on Jun 03, 2018, 12:45 pm
Zumindest die Board-Einstellung wäre schon mal eine große Hilfe.
Sowie die Baudrate beim Serial Monitor...

Die COM Port Zuordnung war schon damals - bei der Basic Stamp - sehr gut und hat mehr geholfen als geschadet.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: hajos118 on Mar 01, 2019, 09:27 am
Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird.
Früher war das immer der zuletzt bearbeitete Sketch.
Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: wapjoe on Mar 02, 2019, 07:46 pm
Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird.
Früher war das immer der zuletzt bearbeitete Sketch.
Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?
It's not a bug, it's a feature... ;)

Geht anscheinend nicht mehr, keine Ahnung ob da dran gearbeitet wird und welche Prio die Funktion hat, aber vielleicht hilft folgende Lösung (geht mit Windows 10, wahrscheinlich auch mit 8 ):

Hefte die IDE an der Taskleiste an und mach nen Rechtsklick auf die Verknüpfung, dann siehst du die zuletzt mit der IDE geöffneten Sketche.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Mar 07, 2019, 06:23 pm
Hab' mir die Version 1.8.8 über die alte Arduino gespielt und festgestellt, dass jetzt beim Start immer ein leerer Sketch geladen wird.
Früher war das immer der zuletzt bearbeitete Sketch.
Gibt's da was zum Einstellen oder handelt es sich um eine unverbesserbare Verbesserung ;-) ?

...beende die IDE mit STRG+Q oder Datei -> beenden.....
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Apr 09, 2019, 10:54 am
Hallo,

ich habe gerade die letzte Version (1.1.10 ?) geladen und installiert. Jetzt geht die IDE wieder mit dem letzten Sketch auf....

Ich habe das mal als portable Installation versucht.
Wie ist das mit den Librarays? Irgendwo habe ich gelesen, man solle in dem extrahierten Verzeichnis ein Verzeichnis "portable" anlegen, dort kommen dann in des Verzeichnis "sketchbook" die Sketche und die Librarays rein. Es gibt aber doch auch im "Hauptverzeichnis Arduino" schon ein Libraray-Verzeichnis. Was hat es denn damit auf sich?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Tommy56 on Apr 09, 2019, 09:23 pm
Die neueste "stabile" Version ist die 1.8.9.

Wo Du eine 1.1.10 ausgegraben hast, weiß ich nicht.

Gruß Tommy
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: uk1408 on Apr 10, 2019, 06:34 pm


...hier.. (https://www.arduino.cc/en/main/software) bei den HOURLY BUILDS.

Kannst du mir trotzdem was zu den Librarays sagen? Und wie gehst du dann bei einem Update vor? Einfach die neue Version auspacken und nur den portabel-Ordner komplett von alten in den neuen Ordner kopieren?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Tommy56 on Apr 10, 2019, 06:54 pm
Das könnte mal eine 1.8.10 werden.

Ich lege für neue Versionen der IDE jeweils ein neues portables Verzeichnis an, dass die Versiponsnummer und manchmal auch die ESP8266-Versionsnummer enthält.

Die Libs, die Du selbst installierst gehören nach <sletchbook>/libraries.

@Uwe: Ich glaube die Diskussion könnte aus diesem Hauptthread abgespalten werden.
Ich weiß aber nicht wo.

Gruß Tommy
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Deltaflyer on Jul 07, 2019, 10:40 am
Hallo Community,
Habe vor ein paar Tagen ein seltsames Verhalten der IDE 1.8.9 unter Win10 entdeckt. Ist die Installierte, also nicht mobile Version.

Und zwar folgendes: ich war am austesten eines touchsensors, der ne 70cm lange Sensorfläche hat. musste deshalb mit den Werten, elektronisch sowie auch programmtechnisch spielen, da die mpfindlichkeit extrem hoch , aber auch recht unstabil war.

Hab dabei immer wieder änderungen am sketch vorgenommen, auch mal das ganze übern haufen geworfen und wieder neu begonnen.

Nun ergab es sich plötzlich, dass der Nano trotz hochladen des Sketches mit neuen Werten immer wieder mit einer älteren version des sketches zu arbeiten schien.

Hab dann den Sketch gespeichert , IDE geschlossen IDE neu gestartet, sketch frisch geladen, - war auch
in der gewünschten Form im Editor zu sehen, kompiliert und hochgeladen, was auch fehlerfrei geklappt hat.
Und dann, spielte der Nano wieder die alte Version des Programms ab - hä???

Ich wollte schon den rechner neu starten, dann sah ich in der taskleiste, dass noch ne Instanz der IDE offen war, hab das Fenster hochgeholt und sehe - die Alte Version meines Sketches!

Aber warum wird denn nicht die Version hochgeladen, aus der Instanz der IDE mit der ich grad arbeite und in der ich auf Kompilieren und Hochladen drücke?


Das Finde ich etwas verwirrend.

Hat da einer von Euch ne Idee dazu?

LG Stefan
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Jul 07, 2019, 12:03 pm
Wenn ich mehrere Projekte gleichzeitig bearbeite, nehme ich immer verschiedene Versionen der IDE, nicht 2 Instanzen derselben Version.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Deltaflyer on Jul 07, 2019, 12:37 pm
Guter Workaround!
Jedoch bleibt die Frage: Warum lädt die IDE den Code aus einer anderen Instanz hoch , anstatt aus der Instanz, mit der ich grad aktiv arbeite und in der ich den Kompilieren/Hochladen Button anklicke?

LG Stefan
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Jul 07, 2019, 07:46 pm
Wenn ich die IDE öffne, lädt die IDE meistens die letzten Sketches, die beim runterfahren geladen war. Zumindest meistens
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Deltaflyer on Jul 07, 2019, 08:02 pm
Ich hatte ja in der Instanz den sketch , den ich hochladen wollte, hab ja daran gearbeitet.
Und in einer weiteren Instanz war der selbe sketch in ner  vorherigen version.
Ich frage mich , warum wird der compillierte code aus einer vorherigen version hochgeladen und nicht derjenige , der gerade frisch erzeugt wurde, oder hätte werden sollen? Meine IDE ist übrigens so eingestellt, dass der sketch vor dem Überprüfen und Hochladen Gespeichert wird.

LG Stefan
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Jul 08, 2019, 11:20 pm
Eine nahezu identische Erfahrung hatte ich auch schon. Bis ich dann irgendwann merkte, dass ich die Versionen verwechselte, also das Problem vor dem Monitor saß.

Wenn du allerdings win10 drauf hast, würde mich gar nichts mehr wundern.  :smiley-evil:
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: Deltaflyer on Jul 09, 2019, 08:23 am
ok dann schaue ich mal, wie es sich auf meinem älteren Laptop , mit win7 verhällt.

LG Stefan
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: dony on Sep 13, 2019, 01:23 pm
Hallo Leute!

Ich hab leider, seit längerem, nicht mehr die Zeit gehabt meinem Arduino Hobby nachzugehen.
Nachdem ich also mehrere Monate nichts mehr gemacht hab, hab ich mir die neueste Arduino IDE (v1.8.9) heruntergeladen und installiert. Davor hatte ich die v.1.8.5. (Windows 10)

Beim starten der IDE bzw. eigentlich nur wenn ich den "Boardmanager" öffne werde ich folgendes gefragt:
Code: [Select]
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?


Die Antwort ist "Ja" aber was bedeutet das bzw. was soll ich machen?

Danke für jede Hilfe!

Grüße,
Donny
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: combie on Sep 13, 2019, 01:54 pm
Hallo Leute!

Ich hab leider, seit längerem, nicht mehr die Zeit gehabt meinem Arduino Hobby nachzugehen.
Nachdem ich also mehrere Monate nichts mehr gemacht hab, hab ich mir die neueste Arduino IDE (v1.8.9) heruntergeladen und installiert. Davor hatte ich die v.1.8.5. (Windows 10)

Beim starten der IDE bzw. eigentlich nur wenn ich den "Boardmanager" öffne werde ich folgendes gefragt:
Code: [Select]
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\bootloaders gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?
Es konnte keine boards.txt in D:\...\Arduino\hardware\Sanguino-master\variants gefunden werden. Ist sie noch von einer Version vor Arduino 1.5?


Die Antwort ist "Ja" aber was bedeutet das bzw. was soll ich machen?

Danke für jede Hilfe!

Grüße,
Donny
Das ist kein Thema für diesen Thread!!!!!
Der hat einen anderen Sinn.

Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: dony on Sep 13, 2019, 02:18 pm
Das ist kein Thema für diesen Thread!!!!!
Der hat einen anderen Sinn.
Entschuldige bitte!  :smiley-confuse:
Was ist dann der Sinn? Ist vielleicht Interpretationssache oder ich übersehe etwas Grundlegendes?
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: ElEspanol on Sep 13, 2019, 05:00 pm
Mach einen neuen Thread dafür auf.
Title: Re: FAQ Neuigkeiten und Probleme ab Arduino IDE 1.0
Post by: dony on Sep 13, 2019, 06:58 pm
Mach einen neuen Thread dafür auf.
Ja, ich bin mittlerweile drauf gekommen das ich ein größeres Problem mit der IDE hab.

Ich versuch es erstmal selber zu lösen, aber danke.