Arduino Forum

Using Arduino => General Electronics => Topic started by: loudboy on Feb 16, 2013, 04:27 am

Title: *Solved* Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 16, 2013, 04:27 am
Here is my circuit:
(http://i101.photobucket.com/albums/m45/loudboy100000000/ScreenShot2013-02-14at113726PM_zps482aa58d.jpg)

Ideally, I will use this circuit to control the brake light and blinkers of my motorcycle (code I wrote seen here: http://arduino.cc/forum/index.php/topic,62948.0.html)
Arduino will monitor the switches, each of which triggers one of the three LEDs. The LEDs are controlled via PWM through MOSFETs. MOSFETs are needed because each LED is rated at 3W. The voltage regulators are used to step down the 12v from the battery to the 5v required by the LEDs.

My problem is that the regulators are using way too much power and getting way too hot: Each regulator/LED is drawing nearly 2A, and the regulator climbs to 130*F in about 20seconds. Also, the regulators start out producing 5v, but almost instantly jump to over 7v and slowly climb to above 9v* before I turn off power to keep the regulator from overheating. In this scenario, the regulator Input-Ground current is 0.002A @12v. These parameters are also replicated when the regulator/LED are wired up directly to the 12v source (independent of the the above illustrated circuit.)

What am I doing wrong? How can I fix this? Is there a better way to drop voltage from 12v to the required 5v? Thanks!


*Edit: I am a bonehead. I was measuring voltage across Input-Output instead of Output-Ground. The regulators work properly, they just get very hot and draw too much power. The solution was to use a resistor. Details below.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: Leon Heller on Feb 16, 2013, 04:32 am
Use switching regulators.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: CrossRoads on Feb 16, 2013, 04:41 am
5V is 600mA for 3W.
What limits the LED current?
Perhaps something is miswired?
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: retrolefty on Feb 16, 2013, 04:43 am
Quote
What am I doing wrong? How can I fix this? Is there a better way to drop voltage from 12v to the required 5v? Thanks!


What you are doing wrong is running your led with constant voltage (5vdc) rather then with a constant current source. Higher power leds need to have their current flow controlled, your just applying 5vdc to them and letting the current be whatever it might be depending on the specific PWM value.

Now one could with by modified wiring and adding a resistor convert the 7805 voltage regulator to perform as a constant current source maybe.

So bottom line your powering method is not up to speed for powering 3 watt leds. You need to look for 3 watt led driver modules for a proper solution.

Lefty
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: billhowl on Feb 16, 2013, 04:49 am
You need to drive your 3W LED with constant current source of 650 to 700mA, you can not use the 5V regulators, the LED about 4V only.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 16, 2013, 04:50 am
Here is my test circuit that is producing the same electrical characteristics as seen in the full circuit seen above. (http://i101.photobucket.com/albums/m45/loudboy100000000/ScreenShot2013-02-15at104744PM_zpscf6b4181.jpg)

Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: CrossRoads on Feb 16, 2013, 04:52 am
Yep, still no current limiting there.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 16, 2013, 04:55 am

Quote
What am I doing wrong? How can I fix this? Is there a better way to drop voltage from 12v to the required 5v? Thanks!


What you are doing wrong is running your led with constant voltage (5vdc) rather then with a constant current source. Higher power leds need to have their current flow controlled, your just applying 5vdc to them and letting the current be whatever it might be depending on the specific PWM value.

Now one could with by modified wiring and adding a resistor convert the 7805 voltage regulator to perform as a constant current source maybe.

So bottom line your powering method is not up to speed for powering 3 watt leds. You need to look for 3 watt led driver modules for a proper solution.

Lefty



Roger that. I'll build this circuit then: http://www.instructables.com/id/Power-LED-s---simplest-light-with-constant-current/
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: CrossRoads on Feb 16, 2013, 04:58 am
Don't forget heatsinks.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 16, 2013, 05:16 am

Don't forget heatsinks.


Got 'em on there already. That was my first move, but then when I started looking into putting together a thermostat circuit to switch on a fan to help cool the heatsinks, I realized I was going down the wrong path and that what I needed was to solve the problem, not the symptoms. Kind of had to slap myself back on track there.

I'll let you all know how this goes, thanks for setting me straight!
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: CrossRoads on Feb 16, 2013, 05:51 am
Will still need the heatsinks, 7V across the 7805 & 600mA is a lot of power being dissipated. (4.2W)

Hence the suggestion to use switching power supply vs linear regulator. Bring the 12V down to something closer to 5V for the 7805 to control as a current source.
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: fungus on Feb 16, 2013, 01:19 pm
You don't need voltage regulators, just a suitable resistor.

a) Find out the LED forward voltage from the datasheet. Usually it's a range of values, (eg. 3.2-3.6V) take the lowest value.

b) Subtract that value from 12V.

c) Use Ohms law to calculate a resistor using the value from (b) and the required current. Round the number upwards a couple of ohms.

d) Find a big wattage resistor with the value calculated in (c), eg. 20-25W. Put it where your voltage regulator is.

nb. You're looking for something like this: http://www.ebay.com/itm/321062578657

There's little LED controllers out there on PCBs but they're less reliable and they'll get HOT (although blinkers/brakes aren't on for much time so that might not be a factor).
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 18, 2013, 09:01 pm
Alright, Fungus, I followed your advice and it worked! (as math should)

I replaced the voltage regulator with a 10ohm, 10W ceramic resistor (http://www.radioshack.com/product/index.jsp?productId=12566075), and it works beautifully! With a supply of 12v, the circuit now draws 0.8A, with about 4v across the LED. The LED is just as bright as ever. The resistor does get very hot though (165*F).
The new circuit:
(http://i101.photobucket.com/albums/m45/loudboy100000000/ScreenShot2013-02-18at30755PM_zps15282c5b.jpg)
The middle and bottom LED can share a resistor because only one can be on at a time (they are the blinkers, and there is no "Hazard" dual flash setting)


Also, I realized that I was having a major bonehead moment when measuring the voltage across my regulators as stated in my first post: I was measuring Output to Input, instead of Output to Ground (d'oh!)

Thanks for the help! As usual, I should remember to K.I.S.S.!
Title: Re: Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: fungus on Feb 18, 2013, 09:25 pm

Alright, Fungus, I followed your advice and it worked! (as math should)


Cool. Thanks for letting me know...!


I replaced the voltage regulator with a 10ohm, 10W ceramic resistor (http://www.radioshack.com/product/index.jsp?productId=12566075), and it works beautifully! With a supply of 12v, the circuit now draws 0.8A, with about 4v across the LED. The LED is just as bright as ever. The resistor does get very hot though (165*F).


In my defense, I did say to get 20W resistors :)

I assume that temperature is for continuous power. It shouldn't get that hot when it's flashing.

What about the LED temperatures? Hope you have a good heatsink for them, too.
Title: Re: *Solved* Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: loudboy on Feb 18, 2013, 09:36 pm
Yes, you did say 20W+, but poor ol' Radio Shack has crap selection. I'll upgrade before going for final installation.

These are the LEDs I'm using: http://www.ledssuperbright.com/3w-led-c-11/3w-high-power-led-aluminum-wide-angle-module-p-218

They have that little inline transformer there that takes 12v and steps it down to 4v, but it also negates PWM control of the speed that I need. The website says that removing the tranformer lets the LED run at 4v, so that's what I did. The aluminum housing keeps the LEDs plenty cool; I've run then for longer periods of time with no noticeable warmth (The brake/running light will be on whenever the bike is on, but dimmed until the brake is used)
Title: Re: *Solved* Voltage Regulators wasting too much power, or "Ouch! Dang that's hot!"
Post by: fungus on Feb 18, 2013, 09:55 pm

These are the LEDs I'm using: http://www.ledssuperbright.com/3w-led-c-11/3w-high-power-led-aluminum-wide-angle-module-p-218

They have that little inline transformer there that takes 12v and steps it down to 4v, but it also negates PWM control of the speed that I need. The website says that removing the tranformer lets the LED run at 4v, so that's what I did. The aluminum housing keeps the LEDs plenty cool; I've run then for longer periods of time with no noticeable warmth (The brake/running light will be on whenever the bike is on, but dimmed until the brake is used)


OK, they look like they're attached to a decent chunk of metal and they're running at design power. Should be fine.

Oh, they do them in UV as well. I've been looking for something like that...  :smiley-surprise: