Arduino Forum

International => Français => Topic started by: neodelavega on Jun 28, 2013, 07:49 pm

Title: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jun 28, 2013, 07:49 pm
salut a tous

je bricole une alarme sans file eden HA500 le bruit émis étant faible est surtout localiser a une seul pièces  je me suis donc lancer dans le démontage de celle si pour l'améliorer

l'idée est de trouver par quoi elle est commander donc sa c'est fait c'est un ATmega88

ensuite avec un multimètre j'ai trouver la sortie qui envoie du 2.4V vers le buzzer juste avent tout le bazar du buzzer (sortie microcontroller)

j'ai donc récupérer se signal  +2.4V est je les mis sur un MOSFET canal N alimenter par une alim pc avec la masse sur la carte de l'alarme donc tout fonctionne parfaitement je retrouve mais 12V en sortie mosfet quand le buzzer retentis  mais le probleme c'est quand phase de mise en service ou quand on alimente la centrale le buzzer se déclenche se qui n'est pas très bon car le buzzer et supportable mais si je couple sur mon mosfet 2 ou 3 sirène sa ne sera plus pareil (pour les voisin aussi)

j'ai donc l'idée de faire une temporisation oui mais comment ? (condensateur ? NE555 ? )

il faudrer que les signal qui dure a peut pres 1 seconde ne sois pas pris en compte par le mosfet

exemple:

1 pulse du ATmega sous 2.4V (buzzer) démarrage de la tempo de 4 seconde mais qui s'interomp car signal present que 1 seconde (aucun déclenchement de sirène extérieur mise a par le buzzer qui lui ne fait pas beaucoup de bruit)

après en période d'effraction le signal étant continue pendant 3 min la tempo se lance 4 seconde puis les sirène retentisse

cela doit être facile a réaliser mais je n'est pas trouver sur google le plus souvent c'est surtout des tempo pour maintenir alimenter une certaine période mais pas pour retarder une action
si vous avez quelque schéma je suis preneur en vous remercient d'avance

Title: Re: tempo pour alarme eden a base ATmega88
Post by: Christian_R on Jun 29, 2013, 08:03 am
Un circuit RC avec une constante de temps assez grande, qui se charge et enclenche un trigger de Schmidt s'il a eu assez de temps pour se charger au dessus du seuil de bascule

http://arduino103.blogspot.fr/2011/12/boutons-contacts-et-deparatisage.html
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jun 29, 2013, 09:30 am
bonjour ok merci pour le lien

donc se serrer se montage
http://3.bp.blogspot.com/-3km5HxXJ5NU/TwCQfKJ-sXI/AAAAAAAABJU/8T-yRnAtUis/s1600/MaterialDebouncedInput.png

je supprime l'inter
le +5V devient la sortie microcontroller 2.4V
gnd sur la carte de l'alarme

le 74HC14 je peut l'alimenter avec la pin du buzzer 2.4V ? il ne me servira pas a autre chose au final il ne fonctionnera que quand les impulsion de 1sec seront presente ou en fonctionnement alarme sur 3 min

et ensuite l'entrer arduino sur le schéma est remplacer par mon mosfet

pour la temporisation je penser prendre une résistance 100K et un condo de 40µf pour avoir aprox 4 seconde
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jun 30, 2013, 10:17 am
bonjour si quelqu'un pourrer me confirmer le schema pour que je puisse lancer la commande

http://img853.imageshack.us/img853/6614/40fu.png
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jun 30, 2013, 06:57 pm
bonjour

personne pour confirmer mon schéma ? c'est assez urgent car RS on les FDP gratuit le weekend est l'alarme doit marcher avent le 8

please !
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 03, 2013, 11:43 am
bonjour

il y a que Christian_R qui connais le trigger de schmidt ? si persone peut me confirmer mon schema y a t'il une autre alternative ?? j'aimerer remonter l'alarme avec la tempo pour qu'elle fonctionne normalement car sinon sa m'oblige a la redémontrer 2 fois et a tout modifier pour implémenter la tempo
Title: Re: tempo pour alarme eden a base ATmega88
Post by: Artouste on Jul 03, 2013, 12:12 pm

bonjour

il y a que Christian_R qui connais le trigger de schmidt ? si persone peut me confirmer mon schema y a t'il une autre alternative ?? j'aimerer remonter l'alarme avec la tempo pour qu'elle fonctionne normalement car sinon sa m'oblige a la redémontrer 2 fois et a tout modifier pour implémenter la tempo

bonjour
oui c'est ok
mais 40µF ce n'est pas une valeur standard 47 oui
et à la place de la 100K je mettrais un potentiometre en RV de 470K pour avoir un reglage hard de tempo
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 03, 2013, 01:02 pm
bonjour artouste

merci pour ta confirmation et pour t'es conseil !! je voulez être sur de pas faire de connerie étant débutant dans le domaine
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 16, 2013, 03:36 pm
Bonjour

j'ai recu les composant pour realiser mon circuit

j'ai tester mais c'est comme si je brancher le mosfet en directe que le potar sois a 100K ou a 500K je ne vois aucun changement

c`est brancher comme sur le schéma 5A sur circuit RC et 5Y sur le MOSFET

la seul idée qui me viens a l'esprit c'est le fait que j'ai employer un condo polariser aluminium ?? ou sa a aucune importance ? car on direr que le condo est bypasser et donc ne se charge pas se qui fait basculer le trigger de SCHMITT immédiatement 

merci par avance
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 18, 2013, 09:53 am
Bonjour des idée ?

J'ai vérifier mon Condo il et bien dans le bon sans et mon potar et bien un 500k défois que jaurer pris un 500ohms je vois pas d'où sa pourrer venir j'ai vérifier 4 fois la bonne disposition de mais composant tout et bien câbler j'ai même inverser le Condo et la par contre sa ne marcher plus du tout j'ai testé avec une Led et elle s'illuminer faiblement et quand il y avez les bip elle s'illuminer normalement bref

Title: Re: tempo pour alarme eden a base ATmega88
Post by: Artouste on Jul 18, 2013, 12:34 pm

Bonjour des idée ?

J'ai vérifier mon Condo il et bien dans le bon sans et mon potar et bien un 500k défois que jaurer pris un 500ohms je vois pas d'où sa pourrer venir j'ai vérifier 4 fois la bonne disposition de mais composant tout et bien câbler j'ai même inverser le Condo et la par contre sa ne marcher plus du tout j'ai testé avec une Led et elle s'illuminer faiblement et quand il y avez les bip elle s'illuminer normalement bref



bonjour
schema et photo du montage ?
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 18, 2013, 02:03 pm
alors le schéma c'est celui si
http://img853.imageshack.us/img853/6614/40fu.png

1 = input 5A
2 = output 5Y

la sortie microcontroller alimente le 74HC14 et aussi le potar 500K

les masse son relier de ma carte a mon alim PC et aussi la carte de l'alarme

voici quelque photo du montage

http://imageshack.us/a/img18/9987/gnxy.jpg
http://imageshack.us/a/img42/1059/6m7o.jpg

le BS170 c'est pour autre chose récupérer la sortie microcontroller et la faire passer par le BS170 pour allumer une led puissante seul le pin S (source) et brancher sur la carte rien d'autre
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 19, 2013, 09:05 pm
Bonsoir

aucune idée ? cela marche au moins avec un trigger de schmitt ?? la référence exact et le SN74HC14N

merci
Title: Re: tempo pour alarme eden a base ATmega88
Post by: Artouste on Jul 20, 2013, 12:47 pm

Bonsoir

aucune idée ? cela marche au moins avec un trigger de schmitt ?? la référence exact et le SN74HC14N

merci

hors connection sur arduino, quel est le temps de montée V aux bornes de C1 .
attention la sortie du CI est Inv
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 20, 2013, 06:57 pm
Alors j'ai tester avent de rentrer dans input 5A et sans arduino

N'ayant pas de 2.4v j'ai testé en 3.3V donc pour arriver a 2.4 volt avec le potar a 500k sa mais 18 seconde approxe

Sa viens de se foutu trigger de schmitt ?

PS: il ne faut pas l'alimenter en continue ? Car j'ai recup la sortie buzzer pour alimenter le 74hc14 (elle n'est donc pas continue )
Title: Re: tempo pour alarme eden a base ATmega88
Post by: Artouste on Jul 21, 2013, 12:13 pm

Alors j'ai tester avent de rentrer dans input 5A et sans arduino

N'ayant pas de 2.4v j'ai testé en 3.3V donc pour arriver a 2.4 volt avec le potar a 500k sa mais 18 seconde approxe

Sa viens de se foutu trigger de schmitt ?

PS: il ne faut pas l'alimenter en continue ? Car j'ai recup la sortie buzzer pour alimenter le 74hc14 (elle n'est donc pas continue )

tu alimente le montage par le signal qu tu veux conditionner ?  $)
Title: Re: tempo pour alarme eden a base ATmega88
Post by: neodelavega on Jul 21, 2013, 12:47 pm
oui exacte comme décrit dans le schéma il demande 0.5v mini

edit: je viens de modifier le circuit en mettant le 74HC14 sur un des régulateur 5V de la carte sa ne marche toujours pas est maintenant le buzzer sonne vraiment moins fort presque inaudible (même quand le buzzer s'arrête la sortie mosfet continue d'être alimenter...) on dirait que le 74HC14 n'est pas approprier pour se montage