Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: Kapiu on Aug 28, 2013, 07:04 am

Title: Arduino Mega2560 uknown usb device
Post by: Kapiu on Aug 28, 2013, 07:04 am
Hi guys, so I've looking for a solution but nothing works, every post of this kind is around the same problem when the device is listed under "Other devices > Unknown device".

I have been working in this device without problem under Win7 for the last couple of months, but suddenly is not working. And currently It's wired to a 16x2 LCD and is performing the sketch, a simple clock.

But since is not been recognized I can't upload anything else.

Now the problem, my device is listed under "Universal Serial Bus controllers > Unknown device" as you can see in the screenshot

(http://www.fokus-dyp.mx/arduino/arduino_fail.jpg)

I've tried to update the driver, but no luck, maybe I'm missing something, something I'm not seeing?

Neither in the manufactures menu is an option for ports.
(http://www.fokus-dyp.mx/arduino/arduino_fail_1.jpg)

Selecting the driver is not working as it doesn't recognize it as the correct driver.
(http://www.fokus-dyp.mx/arduino/arduino_fail_2.jpg)
(http://www.fokus-dyp.mx/arduino/arduino_fail_3.jpg)

At this point I'm not sure what else I can do.



And I can't find a similar problem to mine, hope you can help me, thanks.
Title: Re: Arduino Mega2560 uknown usb device
Post by: craigcurtin on Aug 28, 2013, 11:29 am
Do you have anything else plugged into the USB 2 (not USB3) ports on the machine - are they working OK ?

have you tried plugging the Arduino into the USB 3 port ?

Is this an R3 board ?

Craig
Title: Re: Arduino Mega2560 uknown usb device
Post by: Kapiu on Aug 28, 2013, 07:42 pm
Hi,

Nothing else is plugged but my mouse, I've connected my nano v3 and is working using the same cables.

It's a R1 my board, I'm thinking the USB chip got fried, but I don't know how.

Thanks,
Alex.
Title: Re: Arduino Mega2560 uknown usb device
Post by: nexusbr on Aug 28, 2013, 09:22 pm
try checking the usb cable connection on the motherboard.
also try a different usb port.

=)
Title: Re: Arduino Mega2560 uknown usb device
Post by: mohi2553 on Oct 31, 2014, 05:37 pm
Hi
even I'm confronting the same error..

Did you find any solutions to this error?